aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-11-30 17:29:09 +0000
committerTarmac <Unknown>2012-11-30 17:29:09 +0000
commit7b3703e6ed6bec9f2880a4b40371551077314430 (patch)
treee5503e13d2b8c9a217b99b17e5b766573fe001ae /configure.ac
parent355e2614158629582092c1cd4779419ffaa6dcff (diff)
parent434e53697c99fbe7070671855b7fef97ca7499bc (diff)
downloadayatana-indicator-session-7b3703e6ed6bec9f2880a4b40371551077314430.tar.gz
ayatana-indicator-session-7b3703e6ed6bec9f2880a4b40371551077314430.tar.bz2
ayatana-indicator-session-7b3703e6ed6bec9f2880a4b40371551077314430.zip
i-session doesn't use polkit or packagekit anymore, so don't refer to them in configure.ac or debian/*. Fixes: https://bugs.launchpad.net/bugs/1085100.
Approved by PS Jenkins bot, Mathieu Trudel-Lapierre.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 8 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 390f091..aeff7d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,7 +30,6 @@ GLIB_REQUIRED_VERSION=2.33
GTK_REQUIRED_VERSION=3.0
INDICATOR_REQUIRED_VERSION=0.3.19
DBUSMENUGTK_REQUIRED_VERSION=0.5.90
-POLKIT_REQUIRED_VERSION=0.92
DBUSTEST_REQUIRED_VERSION=0.0.5
DBUSMENUGLIB_REQUIRED_VERSION=0.1.1
@@ -47,8 +46,7 @@ PKG_CHECK_MODULES(SESSIONSERVICE, glib-2.0 >= $GLIB_REQUIRED_VERSION
dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION
dbusmenu-gtk3-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION
gio-unix-2.0
- indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION
- packagekit-glib2)
+ indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION)
AC_SUBST(SESSIONERVICE_CFLAGS)
AC_SUBST(SESSIONERVICE_LIBS)
@@ -60,14 +58,15 @@ AC_SUBST(GUDEV_LIBS)
###########################
AC_ARG_ENABLE([gtklogouthelper],
- AS_HELP_STRING([--enable-gtklogouthelper], [enable GTK Logout Helper]),,
- enable_gtklogouthelper=auto)
+ [AS_HELP_STRING([--enable-gtklogouthelper], [enable GTK Logout Helper])],
+ [],
+ [enable_gtklogouthelper=auto])
if test x"$enable_gtklogouthelper" != x"no" ; then
- PKG_CHECK_MODULES(GTKLOGOUTHELPER, gtk+-3.0 >= $GTK_REQUIRED_VERSION
- polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION,
- [have_gtklogouthelper=yes],
- [have_gtklogouthelper=no])
+ PKG_CHECK_MODULES([GTKLOGOUTHELPER],
+ [gtk+-3.0 >= $GTK_REQUIRED_VERSION],
+ [have_gtklogouthelper=yes],
+ [have_gtklogouthelper=no])
if test x${have_gtklogouthelper} = xyes; then
AC_DEFINE(HAVE_GTKLOGOUTHELPER, 1, [Define to 1 to enable GTK Logout Helper])
fi