aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-11-16 20:00:08 +0000
committerTarmac <Unknown>2012-11-16 20:00:08 +0000
commitdabf87de02616a4c0ba54b35dc5cbab8ef0187be (patch)
treee2fe29e0232f247820e47c2f84155eca0c638fec /configure.ac
parent1f43c3a642d6e8b6bc42b4bc63f232fb2f35dd6c (diff)
parent0ad2ca4e77671f8a7279a58f0e477bac0fe6c554 (diff)
downloadayatana-indicator-session-dabf87de02616a4c0ba54b35dc5cbab8ef0187be.tar.gz
ayatana-indicator-session-dabf87de02616a4c0ba54b35dc5cbab8ef0187be.tar.bz2
ayatana-indicator-session-dabf87de02616a4c0ba54b35dc5cbab8ef0187be.zip
Reimplement test-service s.t. we actually test activating the service via dbus. Drop unneeded Xorg baggage. Fixes: https://bugs.launchpad.net/bugs/1074065.
Approved by PS Jenkins bot.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index d485254..aadb24e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,7 @@ m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
# Dependencies
###########################
+GIO_REQUIRED_VERSION=2.33
GLIB_REQUIRED_VERSION=2.33
GTK_REQUIRED_VERSION=3.0
INDICATOR_REQUIRED_VERSION=0.3.19
@@ -135,16 +136,15 @@ if test "x$enable_tests" != "xno"; then
AC_MSG_ERROR([tests were requested but gtest is not installed.])
fi
if test "x$enable_tests" = "xyes"; then
- PKG_CHECK_MODULES([TEST_SERVICE],[indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION
- dbustest-1 >= $DBUSTEST_REQUIRED_VERSION
- dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION],
- [enable_tests="yes"],
- [enable_tests="no"])
+ PKG_CHECK_MODULES([TEST_SERVICE],[glib-2.0 >= $GLIB_REQUIRED_VERSION
+ gio-2.0 >= $GIO_REQUIRED_VERSION],
+ [enable_tests="yes"],
+ [enable_tests="no"])
fi
fi
AM_CONDITIONAL([BUILD_TESTS],[test "x$enable_tests" = "xyes"])
AC_SUBST([TEST_SERVICE_CFLAGS])
-AC_SUBST([TEST_SERVICE_LDFLAGS])
+AC_SUBST([TEST_SERVICE_LIBS])
##############################
# Custom Junk
@@ -211,6 +211,7 @@ data/icons/scalable/actions/Makefile
data/icons/scalable/status/Makefile
data/extra-sessions/Makefile
tests/Makefile
+tests/indicator-session.service
po/Makefile.in
])