aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2012-04-05 15:07:16 -0400
committerKen VanDine <ken.vandine@canonical.com>2012-04-05 15:07:16 -0400
commit016b902f90a8ea66201dd8f5517ad2557ea4d98d (patch)
tree2f2899f32a41130b1097980df1aac772bba780ae /configure.ac
parent96e1a9f55bedc6ac86bf9a9299bfcc380b7329fb (diff)
parent7897fdf647ff172bfc79aed5bd63fc6f5d52b0a8 (diff)
downloadayatana-indicator-session-016b902f90a8ea66201dd8f5517ad2557ea4d98d.tar.gz
ayatana-indicator-session-016b902f90a8ea66201dd8f5517ad2557ea4d98d.tar.bz2
ayatana-indicator-session-016b902f90a8ea66201dd8f5517ad2557ea4d98d.zip
* New upstream release.
* Remove desktop files so they don't appear in the dash. (LP: #973181) * Add gcov to the build for coverage statistics
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 19 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 1230e8b..1ef7d50 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,7 +4,7 @@ AC_INIT(src/indicator-session.c)
AC_PREREQ(2.53)
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(indicator-session, 0.3.95)
+AM_INIT_AUTOMAKE(indicator-session, 0.3.96)
AM_MAINTAINER_MODE
@@ -198,6 +198,18 @@ AC_DEFINE_PATH(GNOMELOCALEDIR, "${datadir}/locale", [locale directory])
AM_GLIB_GNU_GETTEXT
###########################
+# gcov coverage reporting
+###########################
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AM_CONDITIONAL([HAVE_GCOV], [test "x$ac_cv_check_gcov" = xyes])
+AM_CONDITIONAL([HAVE_LCOV], [test "x$ac_cv_check_lcov" = xyes])
+AM_CONDITIONAL([HAVE_GCOVR], [test "x$ac_cv_check_gcovr" = xyes])
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Files
###########################
@@ -237,9 +249,10 @@ AC_MSG_NOTICE([
SUS Indicator Configuration:
- Prefix: $prefix
- Indicator Dir: $INDICATORDIR
- Indicator GTK: $with_gtk
- Logout Helper: $have_gtklogouthelper
- APT support: $enable_apt
+ Prefix: $prefix
+ Indicator Dir: $INDICATORDIR
+ Indicator GTK: $with_gtk
+ Logout Helper: $have_gtklogouthelper
+ APT support: $enable_apt
+ Coverage reporting: $use_gcov
])