aboutsummaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-08-19 14:32:20 -0500
committerTed Gould <ted@gould.cx>2011-08-19 14:32:20 -0500
commit20b7a5e043b0c751791e775cb96094b53e38cb6f (patch)
tree3e5fdea51c35ab6a751a6fd5f9baacb771bd0372 /data/Makefile.am
parent28389054bde478136f1337577f7bce3d65b03433 (diff)
downloadayatana-indicator-session-20b7a5e043b0c751791e775cb96094b53e38cb6f.tar.gz
ayatana-indicator-session-20b7a5e043b0c751791e775cb96094b53e38cb6f.tar.bz2
ayatana-indicator-session-20b7a5e043b0c751791e775cb96094b53e38cb6f.zip
Setting up convert script and completing the GSettings transition including translations
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 2a9ea62..27328fb 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -10,12 +10,21 @@ dbus_services_DATA = $(service_in_files:.service.in=.service)
sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
@INTLTOOL_SCHEMAS_RULE@
+@INTLTOOL_XML_NOMERGE_RULE@
+
+@GSETTINGS_RULES@
+gsettings_SCHEMAS = com.canonical.indicator.session.gschema.xml
+
+convertdir = $(datadir)/GConf/gsettings
+dist_convert_DATA = indicator-session.convert
+
EXTRA_DIST = \
$(service_in_files) \
- $(schema_in_files)
+ $(gsettings_SCHEMAS:.xml=.xml.in)
+
CLEANFILES = \
$(dbus_services_DATA) \
- $(schema_DATA)
+ $(gsettings_SCHEMAS)