aboutsummaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2012-02-08 15:12:47 -0500
committerKen VanDine <ken.vandine@canonical.com>2012-02-08 15:12:47 -0500
commit4eacd253f0fd5cb22a6c12dbf58126eb14c95bde (patch)
tree27c93878367ff2c04a9b9482b718b71ef8652857 /data/Makefile.am
parent6c05bbbd892c117777b11662b7e86c0d201398ec (diff)
parentfb82208c7c5a593eb89f1a53174978b562fcdae7 (diff)
downloadayatana-indicator-session-4eacd253f0fd5cb22a6c12dbf58126eb14c95bde.tar.gz
ayatana-indicator-session-4eacd253f0fd5cb22a6c12dbf58126eb14c95bde.tar.bz2
ayatana-indicator-session-4eacd253f0fd5cb22a6c12dbf58126eb14c95bde.zip
* New upstream release.
* Screensaver code cleanup * Fix ordering of items on request * Removing GOA support * Fix GTK3 Box Deprecation * Updating to dbusmenu 0.5.90 * Making the gtk logout helper and apt optional build time choices * Add name hints to the indicators * bump version for release * Drop debian/patches/01-remove-dead-gss-handling.patch: Upstream * debian/control: Updating dbusmenu dep to 0.5.90
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am20
1 files changed, 12 insertions, 8 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 7e851a7..3b8de1f 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -18,6 +18,15 @@ gsettings_SCHEMAS = com.canonical.indicator.session.gschema.xml
convertdir = $(datadir)/GConf/gsettings
dist_convert_DATA = indicator-session.convert
+EXTRA_DIST = \
+ $(service_in_files) \
+ $(gsettings_SCHEMAS:.xml=.xml.in)
+
+CLEANFILES = \
+ $(dbus_services_DATA) \
+ $(gsettings_SCHEMAS)
+
+if BUILD_GTKLOGOUTHELPER
@INTLTOOL_DESKTOP_RULE@
%.desktop.in: %.desktop.in.in
@@ -37,14 +46,9 @@ logout_helper_desktop_files = \
$(logout_helper_desktop_in_in_files:.desktop.in.in=.desktop)
logout_helper_DATA = $(logout_helper_desktop_files)
-EXTRA_DIST = \
- $(service_in_files) \
- $(gsettings_SCHEMAS:.xml=.xml.in) \
+EXTRA_DIST += \
$(logout_helper_desktop_in_in_files)
-
-CLEANFILES = \
- $(dbus_services_DATA) \
- $(gsettings_SCHEMAS) \
+CLEANFILES += \
$(logout_helper_desktop_files)
-
+endif