aboutsummaryrefslogtreecommitdiff
path: root/data/extra-sessions/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-05-12 11:28:06 +0200
committerTed Gould <ted@gould.cx>2011-05-12 11:28:06 +0200
commitb3c1ec1c84b26d1cf70b009eb3312d12cec622b1 (patch)
tree970e146f22bf5a74c33ba5542d5c0172c3b09633 /data/extra-sessions/Makefile.am
parenteb2890fecd65d4c2b7750c0f9537dc8b661d0821 (diff)
downloadayatana-indicator-session-b3c1ec1c84b26d1cf70b009eb3312d12cec622b1.tar.gz
ayatana-indicator-session-b3c1ec1c84b26d1cf70b009eb3312d12cec622b1.tar.bz2
ayatana-indicator-session-b3c1ec1c84b26d1cf70b009eb3312d12cec622b1.zip
Making the desktop translatable
Diffstat (limited to 'data/extra-sessions/Makefile.am')
-rw-r--r--data/extra-sessions/Makefile.am18
1 files changed, 14 insertions, 4 deletions
diff --git a/data/extra-sessions/Makefile.am b/data/extra-sessions/Makefile.am
index 2a157ad..e6b81a8 100644
--- a/data/extra-sessions/Makefile.am
+++ b/data/extra-sessions/Makefile.am
@@ -1,14 +1,24 @@
-extra_guests_desktop_in_files = \
- classic-desktop.desktop.in
+###################################
+# The files that are actually here
+###################################
+
+extra_guests_desktop_in_in_files = \
+ classic-desktop.desktop.in.in
extra_guests_sh_files = \
classic-desktop.sh
+###################################
+# Rules to make things work
+###################################
+
extra_guestsdir = $(datadir)/indicators/session/applications/
extra_guests_desktop_files = \
- $(extra_guests_desktop_in_files:.desktop.in=.desktop)
+ $(extra_guests_desktop_in_in_files:.desktop.in.in=.desktop)
+
+@INTLTOOL_DESKTOP_RULE@
-%.desktop: %.desktop.in
+%.desktop.in: %.desktop.in.in
sed -e "s|\@guestdir\@|$(extra_guestsdir)|" $< > $@
extra_guests_DATA = \