aboutsummaryrefslogtreecommitdiff
path: root/data/icons/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-08-07 20:10:15 +0100
committerTed Gould <ted@canonical.com>2009-08-07 20:10:15 +0100
commite1c7ffdac9b07cbfdabde6c5d2854535836d587d (patch)
tree224fcbe5c3d74627fd3497d36d2cde32d862d744 /data/icons/Makefile.am
parent348bd323b895f5d1fd41a4b083e4b49b74717037 (diff)
downloadayatana-indicator-session-e1c7ffdac9b07cbfdabde6c5d2854535836d587d.tar.gz
ayatana-indicator-session-e1c7ffdac9b07cbfdabde6c5d2854535836d587d.tar.bz2
ayatana-indicator-session-e1c7ffdac9b07cbfdabde6c5d2854535836d587d.zip
A whole bunch of icons that are from our previous FUSA patches
Diffstat (limited to 'data/icons/Makefile.am')
-rw-r--r--data/icons/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/data/icons/Makefile.am b/data/icons/Makefile.am
new file mode 100644
index 0000000..17dca13
--- /dev/null
+++ b/data/icons/Makefile.am
@@ -0,0 +1,15 @@
+SUBDIRS = scalable 16x16 22x22 24x24 32x32 48x48
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(pkgdatadir)/icons/hicolor
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+