aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/03_tp_glib.patch
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2009-12-08 08:59:50 -0500
committerKen VanDine <ken.vandine@canonical.com>2009-12-08 08:59:50 -0500
commit91d132773a584144a105fd97bba88eb29572ac56 (patch)
tree83dac234cecfd6f2c5fb958b1e6df549a8e36620 /debian/patches/03_tp_glib.patch
parent035a5078a63a8a2773cd07b5138c6903c0e579ef (diff)
downloadayatana-indicator-session-91d132773a584144a105fd97bba88eb29572ac56.tar.gz
ayatana-indicator-session-91d132773a584144a105fd97bba88eb29572ac56.tar.bz2
ayatana-indicator-session-91d132773a584144a105fd97bba88eb29572ac56.zip
* debian/patches/02_mc5-fixes.patch
- Renamed the patch for ordering * debian/patches/03_tp_glib.patch - Port from libempathy to telepathy-glib (LP: #461367) * debian/patches/99_autoreconf.patch - autoreconf for telepathy change
Diffstat (limited to 'debian/patches/03_tp_glib.patch')
-rw-r--r--debian/patches/03_tp_glib.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/debian/patches/03_tp_glib.patch b/debian/patches/03_tp_glib.patch
new file mode 100644
index 0000000..96bbc0b
--- /dev/null
+++ b/debian/patches/03_tp_glib.patch
@@ -0,0 +1,39 @@
+=== modified file 'configure.ac'
+--- configure.ac 2009-12-08 13:36:06 +0000
++++ configure.ac 2009-12-08 13:40:34 +0000
+@@ -37,10 +37,10 @@
+ AC_SUBST(APPLET_LIBS)
+
+ DBUSMENUGLIB_REQUIRED_VERSION=0.1.1
+-LIBEMPATHY_REQUIRED_VERSION=2.27.0
++TELEPATHYGLIB_REQUIRED_VERSION=0.9.0
+
+ PKG_CHECK_MODULES(STATUSSERVICE, dbusmenu-glib >= $DBUSMENUGLIB_REQUIRED_VERSION
+- libempathy >= $LIBEMPATHY_REQUIRED_VERSION)
++ telepathy-glib >= $TELEPATHYGLIB_REQUIRED_VERSION)
+
+ AC_SUBST(STATUSERVICE_CFLAGS)
+ AC_SUBST(STATUSERVICE_LIBS)
+
+=== modified file 'src/status-provider-mc5.c'
+--- src/status-provider-mc5.c 2009-12-08 13:38:42 +0000
++++ src/status-provider-mc5.c 2009-12-08 13:46:07 +0000
+@@ -24,7 +24,7 @@
+ #include "config.h"
+ #endif
+
+-#include "libempathy/empathy-account-manager.h"
++#include "telepathy-glib/account-manager.h"
+
+ #include "status-provider.h"
+ #include "status-provider-mc5.h"
+@@ -267,7 +267,7 @@
+
+ build_eam(STATUS_PROVIDER_MC5(sp));
+
+- empathy_account_manager_request_global_presence(priv->manager, sp_to_tp_map[status], sp_to_mc_map[status], "");
++ tp_account_manager_set_all_requested_presences(priv->manager, sp_to_tp_map[status], sp_to_mc_map[status], "");
+
+ return;
+ }
+