aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-07-07 11:15:18 -0500
committerTed Gould <ted@gould.cx>2011-07-07 11:15:18 -0500
commit1bfebb7910321dbbd16778d58c553e3f47e46220 (patch)
treec54428e525ee4b2640d22a44475ccfbc92a3ed5c /debian/rules
parent81976a21a0cf3e0035896d9e3c9548773d58e65c (diff)
parent31c18f6eda48e5ce6f28231585c53a53bd971e04 (diff)
downloadayatana-indicator-session-1bfebb7910321dbbd16778d58c553e3f47e46220.tar.gz
ayatana-indicator-session-1bfebb7910321dbbd16778d58c553e3f47e46220.tar.bz2
ayatana-indicator-session-1bfebb7910321dbbd16778d58c553e3f47e46220.zip
Sync to U. Desktop
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules23
1 files changed, 16 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index 8db591a..c8bc001 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,15 +1,24 @@
#!/usr/bin/make -f
+DEB_BUILDDIR = build
+DEB_MAKE_FLAVORS = gtk2 gtk3
+
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/gnome.mk
-include /usr/share/cdbs/1/rules/simple-patchsys.mk
-LDFLAGS += -Wl,-z,defs -Wl,--as-needed
+DEB_MAKE_DESTDIRSKEL = $(CURDIR)/debian/tmp/@FLAVOR@
+DEB_DESTDIR = $(CURDIR)/debian/tmp/$(cdbs_make_curflavor)/
-DEB_DH_MAKESHLIBS_ARGS = -Xusr/lib/indicators
+DEB_CONFIGURE_FLAGS_gtk2 = --with-indicator-gtk=2
+DEB_CONFIGURE_FLAGS_gtk3 = --with-indicator-gtk=3
+DEB_CONFIGURE_EXTRA_FLAGS = --disable-static
+
+LDFLAGS += -Wl,-z,defs -Wl,--as-needed
-binary-install/indicator-session::
- # remove .a/.la clutter
- rm -f debian/$(cdbs_curpkg)/usr/lib/indicators/*/*.a
- rm -f debian/$(cdbs_curpkg)/usr/lib/indicators/*/*.la
+debian/stamp-autotools/gtk2: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk2)
+debian/stamp-autotools/gtk3: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk3)
+common-install-arch::
+ find debian/tmp -name \*.la -delete
+ find debian/tmp -name \*.a -delete
+ find debian/tmp -name classic-desktop.sh | xargs chmod +x