aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSebastien Bacher <seb128@ubuntu.com>2010-03-23 18:59:37 +0100
committerSebastien Bacher <seb128@ubuntu.com>2010-03-23 18:59:37 +0100
commit81db14844ae153486cd472e1186d98b33865a23a (patch)
tree23af34d1d82cc3de60c4f766a31b055325eeab7a /debian
parent585f1180a33057220f2afc5dae896ed44045f99c (diff)
downloadayatana-indicator-session-81db14844ae153486cd472e1186d98b33865a23a.tar.gz
ayatana-indicator-session-81db14844ae153486cd472e1186d98b33865a23a.tar.bz2
ayatana-indicator-session-81db14844ae153486cd472e1186d98b33865a23a.zip
releasing version 0.2.6-0ubuntu2
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog12
-rw-r--r--debian/control3
-rw-r--r--debian/patches/restore_lock_screen.patch19
3 files changed, 33 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 2c47ae3..6e3be30 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+indicator-session (0.2.6-0ubuntu2) lucid; urgency=low
+
+ * debian/control:
+ - change the gdm Depends to a Suggests since it's not really needed
+ * debian/patches/restore_lock_screen.patch:
+ - don't change "lock screen" in "start screensaver" for users who don't
+ use lock on screensaver action by default, the behaviour change was
+ breaking freeze and letting some users without a way to lock their
+ computer screen (lp: #542585)
+
+ -- Sebastien Bacher <seb128@ubuntu.com> Tue, 23 Mar 2010 18:50:35 +0100
+
indicator-session (0.2.6-0ubuntu1) lucid; urgency=low
* Upstream release 0.2.6
diff --git a/debian/control b/debian/control
index 00b5263..c1b4123 100644
--- a/debian/control
+++ b/debian/control
@@ -20,7 +20,8 @@ Vcs-Browser: http://bazaar.launchpad.net/~ubuntu-desktop/indicator-session/ubunt
Package: indicator-session
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, indicator-applet (>= 0.2), upower, gdm
+Depends: ${shlibs:Depends}, ${misc:Depends}, indicator-applet (>= 0.2), upower
+Suggests: gdm
Conflicts: gdm (<= 2.27.4-0ubuntu9), indicator-sus
Replaces: indicator-sus
Description: An indicator showing session management, status and user switching.
diff --git a/debian/patches/restore_lock_screen.patch b/debian/patches/restore_lock_screen.patch
new file mode 100644
index 0000000..12a24d4
--- /dev/null
+++ b/debian/patches/restore_lock_screen.patch
@@ -0,0 +1,19 @@
+=== modified file 'src/lock-helper.c'
+--- src/lock-helper.c 2010-03-18 19:19:39 +0000
++++ src/lock-helper.c 2010-03-23 17:47:37 +0000
+@@ -131,11 +131,12 @@
+ return FALSE;
+ }
+
+- if (gconf_client == NULL) {
++ /* if (gconf_client == NULL) {
+ gconf_client = gconf_client_get_default();
+ }
+
+- return gconf_client_get_bool (gconf_client, GCONF_KEY, NULL);
++ return gconf_client_get_bool (gconf_client, GCONF_KEY, NULL); */
++ return TRUE;
+ }
+
+ /* When the screensave go active, if we've got a mainloop
+