aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2013-07-12 14:58:31 +0000
committerTarmac <Unknown>2013-07-12 14:58:31 +0000
commit550b78d3ce87fcbf446b4d9e70f93214c6d1c72a (patch)
tree54b1593439a2ef0e69d30a3b8cb891d865db9d31 /src/CMakeLists.txt
parentabf13603f580a2041b661dd0c81bdb0d95b92051 (diff)
parenta19955f3f81b1a5eb8fc928bc5dcf8a24bb6833f (diff)
downloadayatana-indicator-session-550b78d3ce87fcbf446b4d9e70f93214c6d1c72a.tar.gz
ayatana-indicator-session-550b78d3ce87fcbf446b4d9e70f93214c6d1c72a.tar.bz2
ayatana-indicator-session-550b78d3ce87fcbf446b4d9e70f93214c6d1c72a.zip
This is the GMenu, login1 version of indicator-session.
This resubmission removes the prerequisite branch because the entire diff is contained in this ng-login1 branch. Approved by PS Jenkins bot.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..a00b6f1
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,27 @@
+add_subdirectory (backend-dbus)
+
+add_library (libindicatorsessionservice STATIC
+ actions.c
+ actions.h
+ guest.c
+ guest.h
+ service.c
+ service.h
+ users.c
+ users.h)
+include_directories(${SERVICE_INCLUDE_DIRS})
+link_directories(${SERVICE_LIBRARY_DIRS})
+
+set (SERVICE_EXEC "indicator-session-service")
+set_property (SOURCE main.c
+ APPEND PROPERTY COMPILE_DEFINITIONS
+ GETTEXT_PACKAGE="${GETTEXT_PACKAGE}"
+ GNOMELOCALEDIR="@CMAKE_INSTALL_FULL_LOCALEDIR@")
+add_executable (${SERVICE_EXEC} main.c)
+target_link_libraries (${SERVICE_EXEC} libindicatorsessionservice backenddbus ${SERVICE_LIBRARIES} ${GCOV_LIBS})
+install (TARGETS ${SERVICE_EXEC} RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_PKGLIBEXECDIR})
+
+# common properties
+set_property (TARGET libindicatorsessionservice ${SERVICE_EXEC}
+ APPEND_STRING PROPERTY COMPILE_FLAGS
+ " -g ${CC_WARNING_ARGS} ${GCOV_FLAGS}")