aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-03-03 15:49:41 -0600
committerTed Gould <ted@gould.cx>2010-03-03 15:49:41 -0600
commit68d13604c069937cdb1e6cab3ecd54cfb45fc593 (patch)
tree605c42d8e48bb36ce85844a72c721bb20569a107 /src/Makefile.am
parentd9dd91ad86cfff9457140ee4debd68752e79a99c (diff)
downloadayatana-indicator-session-68d13604c069937cdb1e6cab3ecd54cfb45fc593.tar.gz
ayatana-indicator-session-68d13604c069937cdb1e6cab3ecd54cfb45fc593.tar.bz2
ayatana-indicator-session-68d13604c069937cdb1e6cab3ecd54cfb45fc593.zip
Flattening the build tree.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am31
1 files changed, 28 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a07c782..cd525bd 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,7 @@
-SUBDIRS = gtk-dialog
-libexec_PROGRAMS = indicator-session-service
+libexec_PROGRAMS = \
+ indicator-session-service \
+ gtk-logout-helper
###################
# Indicator Stuff
@@ -50,13 +51,37 @@ indicator_session_service_SOURCES = \
lock-helper.h \
session-service.c \
dbusmenu-shared.h \
- gtk-dialog/gconf-helper.c \
+ gconf-helper.c \
users-service-dbus.h \
users-service-dbus.c \
users-service-marshal.c
indicator_session_service_CFLAGS = $(SESSIONSERVICE_CFLAGS) $(GCONF_CFLAGS) -DLIBEXECDIR=\"$(libexecdir)\" -Wall -Werror
indicator_session_service_LDADD = $(SESSIONSERVICE_LIBS) $(GCONF_LIBS)
+#################
+# GTK Logout Stuff
+#################
+
+gtk_logout_helper_SOURCES = \
+ gtk-logout-helper.c \
+ gconf-helper.c \
+ gconf-helper.h \
+ dialog.c \
+ dialog.h
+
+gtk_logout_helper_CFLAGS = \
+ $(SESSIONSERVICE_CFLAGS) \
+ $(GTKLOGOUTHELPER_CFLAGS) \
+ $(GCONF_CFLAGS) \
+ -Wall -Werror \
+ -DINDICATOR_ICONS_DIR="\"$(INDICATORICONSDIR)\""
+
+gtk_logout_helper_LDADD = \
+ $(SESSIONSERVICE_LIBS) \
+ $(GTKLOGOUTHELPER_LIBS) \
+ $(GCONF_LIBS)
+
+
###############
# Other Stuff
###############