aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-01-05 22:39:03 -0600
committerTed Gould <ted@gould.cx>2010-01-05 22:39:03 -0600
commit095055acb1af84c4fafb9d844d9657bdc79fe224 (patch)
tree4bb90899bb3c61b0c657fec1b39bdfabfa604453 /src/Makefile.am
parent580cf67b9db257743ab9e55d5a11e885d4a59640 (diff)
parenta2d2135f87d23b9749beae32bfac606170edf8b4 (diff)
downloadayatana-indicator-session-095055acb1af84c4fafb9d844d9657bdc79fe224.tar.gz
ayatana-indicator-session-095055acb1af84c4fafb9d844d9657bdc79fe224.tar.bz2
ayatana-indicator-session-095055acb1af84c4fafb9d844d9657bdc79fe224.zip
Removing the status bits and pieces (they're now in indicator-me) and merging users and session so that we only have one service and one menu. Nice and simple.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am107
1 files changed, 5 insertions, 102 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6a5fc44..e5d5a3c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,6 @@
SUBDIRS = gtk-dialog
-libexec_PROGRAMS = indicator-status-service indicator-users-service indicator-session-service
+libexec_PROGRAMS = indicator-session-service
###################
# Indicator Stuff
@@ -11,41 +11,11 @@ sessionlib_LTLIBRARIES = libsession.la
libsession_la_SOURCES = \
indicator-session.c \
dbus-shared-names.h \
- status-service-client.h \
users-service-client.h
libsession_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Werror
libsession_la_LIBADD = $(APPLET_LIBS)
libsession_la_LDFLAGS = -module -avoid-version
-################
-# Status Stuff
-################
-
-indicator_status_service_SOURCES = \
- status-service.c \
- status-service-dbus.h \
- status-service-dbus.c \
- status-service-server.h \
- users-service-dbus.h \
- users-service-dbus.c \
- users-service-marshal.c \
- users-service-marshal.h \
- status-provider.h \
- status-provider.c \
- status-provider-mc5.h \
- status-provider-mc5.c \
- status-provider-mc5-marshal.h \
- status-provider-mc5-marshal.c \
- status-provider-pidgin.h \
- status-provider-pidgin.c \
- status-provider-pidgin-marshal.h \
- status-provider-pidgin-marshal.c \
- status-provider-telepathy.h \
- status-provider-telepathy.c \
- status-provider-telepathy-marshal.h \
- status-provider-telepathy-marshal.c
-indicator_status_service_CFLAGS = $(STATUSSERVICE_CFLAGS) -Wall -Werror
-indicator_status_service_LDADD = $(STATUSSERVICE_LIBS)
users-service-client.h: $(srcdir)/users-service.xml
dbus-binding-tool \
@@ -54,20 +24,6 @@ users-service-client.h: $(srcdir)/users-service.xml
--output=users-service-client.h \
$(srcdir)/users-service.xml
-status-service-client.h: $(srcdir)/status-service.xml
- dbus-binding-tool \
- --prefix=_status_service_client \
- --mode=glib-client \
- --output=status-service-client.h \
- $(srcdir)/status-service.xml
-
-status-service-server.h: $(srcdir)/status-service.xml
- dbus-binding-tool \
- --prefix=_status_service_server \
- --mode=glib-server \
- --output=status-service-server.h \
- $(srcdir)/status-service.xml
-
users-service-marshal.h: $(srcdir)/users-service.list
glib-genmarshal --header \
--prefix=_users_service_marshal $(srcdir)/users-service.list \
@@ -78,49 +34,6 @@ users-service-marshal.c: $(srcdir)/users-service.list
--prefix=_users_service_marshal $(srcdir)/users-service.list \
> users-service-marshal.c
-status-provider-pidgin-marshal.h: $(srcdir)/status-provider-pidgin.list
- glib-genmarshal --header \
- --prefix=_status_provider_pidgin_marshal $(srcdir)/status-provider-pidgin.list \
- > status-provider-pidgin-marshal.h
-
-status-provider-pidgin-marshal.c: $(srcdir)/status-provider-pidgin.list
- glib-genmarshal --body \
- --prefix=_status_provider_pidgin_marshal $(srcdir)/status-provider-pidgin.list \
- > status-provider-pidgin-marshal.c
-
-status-provider-telepathy-marshal.h: $(srcdir)/status-provider-telepathy.list
- glib-genmarshal --header \
- --prefix=_status_provider_telepathy_marshal $(srcdir)/status-provider-telepathy.list \
- > status-provider-telepathy-marshal.h
-
-status-provider-telepathy-marshal.c: $(srcdir)/status-provider-telepathy.list
- glib-genmarshal --body \
- --prefix=_status_provider_telepathy_marshal $(srcdir)/status-provider-telepathy.list \
- > status-provider-telepathy-marshal.c
-
-status-provider-mc5-marshal.h: $(srcdir)/status-provider-mc5.list
- glib-genmarshal --header \
- --prefix=_status_provider_mc5_marshal $(srcdir)/status-provider-mc5.list \
- > status-provider-mc5-marshal.h
-
-status-provider-mc5-marshal.c: $(srcdir)/status-provider-mc5.list
- glib-genmarshal --body \
- --prefix=_status_provider_mc5_marshal $(srcdir)/status-provider-mc5.list \
- > status-provider-mc5-marshal.c
-
-###############
-# Users Stuff
-###############
-
-indicator_users_service_SOURCES = \
- lock-helper.c \
- lock-helper.h \
- users-service.c \
- users-service-dbus.c \
- users-service-marshal.c
-indicator_users_service_CFLAGS = $(USERSSERVICE_CFLAGS) -Wall -Werror
-indicator_users_service_LDADD = $(USERSSERVICE_LIBS)
-
#################
# Session Stuff
#################
@@ -129,7 +42,9 @@ indicator_session_service_SOURCES = \
lock-helper.c \
lock-helper.h \
session-service.c \
- gtk-dialog/gconf-helper.c
+ gtk-dialog/gconf-helper.c \
+ users-service-dbus.c \
+ users-service-marshal.c
indicator_session_service_CFLAGS = $(SESSIONSERVICE_CFLAGS) $(GCONF_CFLAGS) -DLIBEXECDIR=\"$(libexecdir)\" -Wall -Werror
indicator_session_service_LDADD = $(SESSIONSERVICE_LIBS) $(GCONF_LIBS)
@@ -139,22 +54,10 @@ indicator_session_service_LDADD = $(SESSIONSERVICE_LIBS) $(GCONF_LIBS)
BUILT_SOURCES = \
users-service-client.h \
- status-service-client.h \
- status-service-server.h \
- status-provider-mc5-marshal.h \
- status-provider-mc5-marshal.c \
users-service-marshal.h \
- users-service-marshal.c \
- status-provider-pidgin-marshal.h \
- status-provider-pidgin-marshal.c \
- status-provider-telepathy-marshal.h \
- status-provider-telepathy-marshal.c
+ users-service-marshal.c
EXTRA_DIST = \
- status-service.xml \
- status-provider-mc5.list \
- status-provider-pidgin.list \
- status-provider-telepathy.list \
users-service.xml \
users-service.list