aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGyörgy Balló <ballogy@freestart.hu>2011-11-23 22:58:41 +0100
committerGyörgy Balló <ballogy@freestart.hu>2011-11-23 22:58:41 +0100
commit5a3df0dde62593659e792f92236a8142087080f7 (patch)
tree52fd1d3c6d8072e8d21eecb8428c279c107e4dad /src/Makefile.am
parentf2b3d4838b6a175458f903aeb8a8d04fe7a842a5 (diff)
downloadayatana-indicator-session-5a3df0dde62593659e792f92236a8142087080f7.tar.gz
ayatana-indicator-session-5a3df0dde62593659e792f92236a8142087080f7.tar.bz2
ayatana-indicator-session-5a3df0dde62593659e792f92236a8142087080f7.zip
Make GTK Logout Helper optional
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index dba0a9e..5209869 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,7 +1,11 @@
libexec_PROGRAMS = \
- indicator-session-service \
+ indicator-session-service
+
+if BUILD_GTKLOGOUTHELPER
+libexec_PROGRAMS += \
gtk-logout-helper
+endif
###################
# Indicator Stuff
@@ -124,6 +128,7 @@ indicator_session_service_LDADD = \
# GTK Logout Stuff
#################
+if BUILD_GTKLOGOUTHELPER
gtk_logout_helper_SOURCES = \
gtk-logout-helper.c \
settings-helper.c \
@@ -142,6 +147,7 @@ gtk_logout_helper_LDADD = \
$(SESSIONSERVICE_LIBS) \
$(GTKLOGOUTHELPER_LIBS) \
$(GCONF_LIBS)
+endif
###############