aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCody Russell <crussell@canonical.com>2009-09-22 14:52:45 -0500
committerCody Russell <crussell@canonical.com>2009-09-22 14:52:45 -0500
commit91c2993398771ca1ff5a65003c681724291d9e2f (patch)
treebe53541fe414dd54cf004797adb0f98acc31ff09 /src/Makefile.am
parent51bdf6d04ac6b98019c760c7f12f4315c09cdcb8 (diff)
downloadayatana-indicator-session-91c2993398771ca1ff5a65003c681724291d9e2f.tar.gz
ayatana-indicator-session-91c2993398771ca1ff5a65003c681724291d9e2f.tar.bz2
ayatana-indicator-session-91c2993398771ca1ff5a65003c681724291d9e2f.zip
dbus fu updates
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ffce9b3..6404af0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -29,6 +29,8 @@ indicator_status_service_SOURCES = \
users-service-dbus.h \
users-service-dbus.c \
users-service-server.h \
+ users-service-marshal.c \
+ users-service-marshal.h \
status-provider.h \
status-provider.c \
status-provider-pidgin.h \
@@ -70,6 +72,16 @@ status-service-server.h: $(srcdir)/status-service.xml
--output=status-service-server.h \
$(srcdir)/status-service.xml
+users-service-marshal.h: $(srcdir)/users-service.list
+ glib-genmarshal --header \
+ --prefix=_users_service_marshal $(srcdir)/users-service.list \
+ > users-service-marshal.h
+
+users-service-marshal.c: $(srcdir)/users-service.list
+ glib-genmarshal --body \
+ --prefix=_users_service_marshal $(srcdir)/users-service.list \
+ > users-service-marshal.c
+
status-provider-pidgin-marshal.h: $(srcdir)/status-provider-pidgin.list
glib-genmarshal --header \
--prefix=_status_provider_pidgin_marshal $(srcdir)/status-provider-pidgin.list \
@@ -94,7 +106,7 @@ status-provider-telepathy-marshal.c: $(srcdir)/status-provider-telepathy.list
# Users Stuff
###############
-indicator_users_service_SOURCES = users-service.c users-service-dbus.c
+indicator_users_service_SOURCES = users-service.c users-service-dbus.c users-service-marshal.c
indicator_users_service_CFLAGS = $(USERSSERVICE_CFLAGS) -Wall -Werror
indicator_users_service_LDADD = $(USERSSERVICE_LIBS)
@@ -115,6 +127,8 @@ BUILT_SOURCES = \
users-service-server.h \
status-service-client.h \
status-service-server.h \
+ users-service-marshal.h \
+ users-service-marshal.c \
status-provider-pidgin-marshal.h \
status-provider-pidgin-marshal.c \
status-provider-telepathy-marshal.h \