aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-08-25 16:21:44 -0500
committerTed Gould <ted@canonical.com>2009-08-25 16:21:44 -0500
commita4b4a9271212b8a9370fb7aa461302c6f9a97111 (patch)
tree67027342bfdc8363433a16c613fa0119a5bb48a9 /src/Makefile.am
parentfaef72466956d377bfd5d679ea173db7617a5253 (diff)
parent2ca0db49f3d75fe732885cbad2ba89c4c71beb93 (diff)
downloadayatana-indicator-session-a4b4a9271212b8a9370fb7aa461302c6f9a97111.tar.gz
ayatana-indicator-session-a4b4a9271212b8a9370fb7aa461302c6f9a97111.tar.bz2
ayatana-indicator-session-a4b4a9271212b8a9370fb7aa461302c6f9a97111.zip
Merging in the more status branch that implements basic status for Pidgin and Telepathy.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am38
1 files changed, 35 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index bd35910..599b70a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -28,7 +28,13 @@ indicator_status_service_SOURCES = \
status-provider.h \
status-provider.c \
status-provider-pidgin.h \
- status-provider-pidgin.c
+ status-provider-pidgin.c \
+ status-provider-pidgin-marshal.h \
+ status-provider-pidgin-marshal.c \
+ status-provider-telepathy.h \
+ status-provider-telepathy.c \
+ status-provider-telepathy-marshal.h \
+ status-provider-telepathy-marshal.c
indicator_status_service_CFLAGS = $(STATUSSERVICE_CFLAGS) -Wall -Werror
indicator_status_service_LDADD = $(STATUSSERVICE_LIBS)
@@ -46,6 +52,26 @@ status-service-server.h: $(srcdir)/status-service.xml
--output=status-service-server.h \
$(srcdir)/status-service.xml
+status-provider-pidgin-marshal.h: $(srcdir)/status-provider-pidgin.list
+ glib-genmarshal --header \
+ --prefix=_status_provider_pidgin_marshal $(srcdir)/status-provider-pidgin.list \
+ > status-provider-pidgin-marshal.h
+
+status-provider-pidgin-marshal.c: $(srcdir)/status-provider-pidgin.list
+ glib-genmarshal --body \
+ --prefix=_status_provider_pidgin_marshal $(srcdir)/status-provider-pidgin.list \
+ > status-provider-pidgin-marshal.c
+
+status-provider-telepathy-marshal.h: $(srcdir)/status-provider-telepathy.list
+ glib-genmarshal --header \
+ --prefix=_status_provider_telepathy_marshal $(srcdir)/status-provider-telepathy.list \
+ > status-provider-telepathy-marshal.h
+
+status-provider-telepathy-marshal.c: $(srcdir)/status-provider-telepathy.list
+ glib-genmarshal --body \
+ --prefix=_status_provider_telepathy_marshal $(srcdir)/status-provider-telepathy.list \
+ > status-provider-telepathy-marshal.c
+
###############
# Users Stuff
###############
@@ -68,10 +94,16 @@ indicator_session_service_LDADD = $(SESSIONSERVICE_LIBS)
BUILT_SOURCES = \
status-service-client.h \
- status-service-server.h
+ status-service-server.h \
+ status-provider-pidgin-marshal.h \
+ status-provider-pidgin-marshal.c \
+ status-provider-telepathy-marshal.h \
+ status-provider-telepathy-marshal.c
EXTRA_DIST = \
- status-service.xml
+ status-service.xml \
+ status-provider-pidgin.list \
+ status-provider-telepathy.list
CLEANFILES = \
$(BUILT_SOURCES)