aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-03-16 20:32:20 -0500
committerTed Gould <ted@gould.cx>2010-03-16 20:32:20 -0500
commit9d36c2090992551a961005bf359cdab739c8beed (patch)
tree139cb0de78964bf103b5a64e5751a6574576b598 /src/Makefile.am
parent94cd451d64dec28a5649038b3de1c5971f8f6137 (diff)
downloadayatana-indicator-session-9d36c2090992551a961005bf359cdab739c8beed.tar.gz
ayatana-indicator-session-9d36c2090992551a961005bf359cdab739c8beed.tar.bz2
ayatana-indicator-session-9d36c2090992551a961005bf359cdab739c8beed.zip
Adding in the GDM local display DBus interface spec.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index db41db6..01a88a3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -26,6 +26,13 @@ consolekit-manager-client.h: $(srcdir)/consolekit-manager.xml
--output=consolekit-manager-client.h \
$(srcdir)/consolekit-manager.xml
+gdm-local-display-factory-client.h: $(srcdir)/gdm-local-display-factory.xml
+ dbus-binding-tool \
+ --prefix=_gdm_local_display_factory_client \
+ --mode=glib-client \
+ --output=gdm-local-display-factory-client.h \
+ $(srcdir)/gdm-local-display-factory.xml
+
users-service-client.h: $(srcdir)/users-service.xml
dbus-binding-tool \
--prefix=_users_service_client \
@@ -113,6 +120,7 @@ gtk_logout_helper_LDADD = \
BUILT_SOURCES = \
consolekit-manager-client.h \
+ gdm-local-display-factory-client.h \
session-dbus-client.h \
session-dbus-server.h \
upower-client.h \
@@ -122,6 +130,7 @@ BUILT_SOURCES = \
EXTRA_DIST = \
consolekit-manager.xml \
+ gdm-local-display-factory.xml \
session-dbus.xml \
upower.xml \
users-service.xml \