aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChristoph Korn <korn@ubuntu>2009-09-02 16:17:44 +0200
committerChristoph Korn <korn@ubuntu>2009-09-02 16:17:44 +0200
commit1f0874253406566587d4e42a9ee2f4617a5c66d9 (patch)
treecd8a07328b4a7fcdf836e6596c311a0640e2cf2d /src/Makefile.am
parent41f1b3206ab13b008aed6670dc42636049c9590d (diff)
downloadayatana-indicator-session-1f0874253406566587d4e42a9ee2f4617a5c66d9.tar.gz
ayatana-indicator-session-1f0874253406566587d4e42a9ee2f4617a5c66d9.tar.bz2
ayatana-indicator-session-1f0874253406566587d4e42a9ee2f4617a5c66d9.zip
These patches introduce a gconf key whether the logout/restart/shutdown confirmations
should be shown or not. Also the menu items should be suffixed by '...' accordingly. However this only works after a restart. Bugs which get fixed are: https://bugs.launchpad.net/indicator-session/+bug/422025 https://bugs.launchpad.net/ubuntu/+source/indicator-session/+bug/421693 https://bugs.launchpad.net/ubuntu/+source/indicator-session/+bug/419472
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 599b70a..e2f0008 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -84,9 +84,9 @@ indicator_users_service_LDADD = $(USERSSERVICE_LIBS)
# Session Stuff
#################
-indicator_session_service_SOURCES = session-service.c
-indicator_session_service_CFLAGS = $(SESSIONSERVICE_CFLAGS) -DLIBEXECDIR=\"$(libexecdir)\" -Wall -Werror
-indicator_session_service_LDADD = $(SESSIONSERVICE_LIBS)
+indicator_session_service_SOURCES = session-service.c gtk-dialog/gconf-helper.c
+indicator_session_service_CFLAGS = $(SESSIONSERVICE_CFLAGS) $(GCONF_CFLAGS) -DLIBEXECDIR=\"$(libexecdir)\" -Wall -Werror
+indicator_session_service_LDADD = $(SESSIONSERVICE_LIBS) $(GCONF_LIBS)
###############
# Other Stuff