aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2009-08-27 14:52:00 -0400
committerKen VanDine <ken.vandine@canonical.com>2009-08-27 14:52:00 -0400
commitf6d0564a4d48f60e52959eeb0cdc64c6170e0372 (patch)
treefaac1c5ff643a6aba420f2248ac0390f317ad685 /src/Makefile.am
parent3a18ed4b656b9ee146e6f3fd5fdd56416d335724 (diff)
parent94f3cd1c8817d7203c5ba2b9abb57992f577f3a0 (diff)
downloadayatana-indicator-session-f6d0564a4d48f60e52959eeb0cdc64c6170e0372.tar.gz
ayatana-indicator-session-f6d0564a4d48f60e52959eeb0cdc64c6170e0372.tar.bz2
ayatana-indicator-session-f6d0564a4d48f60e52959eeb0cdc64c6170e0372.zip
* Upstream version 0.1
* debian/control: Looking for libdbusmenu* >= 0.1.0 * debian/control: Shortening the short description and lengthening the long one. Fixes a bug (LP: #412024)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am38
1 files changed, 35 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index bd35910..599b70a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -28,7 +28,13 @@ indicator_status_service_SOURCES = \
status-provider.h \
status-provider.c \
status-provider-pidgin.h \
- status-provider-pidgin.c
+ status-provider-pidgin.c \
+ status-provider-pidgin-marshal.h \
+ status-provider-pidgin-marshal.c \
+ status-provider-telepathy.h \
+ status-provider-telepathy.c \
+ status-provider-telepathy-marshal.h \
+ status-provider-telepathy-marshal.c
indicator_status_service_CFLAGS = $(STATUSSERVICE_CFLAGS) -Wall -Werror
indicator_status_service_LDADD = $(STATUSSERVICE_LIBS)
@@ -46,6 +52,26 @@ status-service-server.h: $(srcdir)/status-service.xml
--output=status-service-server.h \
$(srcdir)/status-service.xml
+status-provider-pidgin-marshal.h: $(srcdir)/status-provider-pidgin.list
+ glib-genmarshal --header \
+ --prefix=_status_provider_pidgin_marshal $(srcdir)/status-provider-pidgin.list \
+ > status-provider-pidgin-marshal.h
+
+status-provider-pidgin-marshal.c: $(srcdir)/status-provider-pidgin.list
+ glib-genmarshal --body \
+ --prefix=_status_provider_pidgin_marshal $(srcdir)/status-provider-pidgin.list \
+ > status-provider-pidgin-marshal.c
+
+status-provider-telepathy-marshal.h: $(srcdir)/status-provider-telepathy.list
+ glib-genmarshal --header \
+ --prefix=_status_provider_telepathy_marshal $(srcdir)/status-provider-telepathy.list \
+ > status-provider-telepathy-marshal.h
+
+status-provider-telepathy-marshal.c: $(srcdir)/status-provider-telepathy.list
+ glib-genmarshal --body \
+ --prefix=_status_provider_telepathy_marshal $(srcdir)/status-provider-telepathy.list \
+ > status-provider-telepathy-marshal.c
+
###############
# Users Stuff
###############
@@ -68,10 +94,16 @@ indicator_session_service_LDADD = $(SESSIONSERVICE_LIBS)
BUILT_SOURCES = \
status-service-client.h \
- status-service-server.h
+ status-service-server.h \
+ status-provider-pidgin-marshal.h \
+ status-provider-pidgin-marshal.c \
+ status-provider-telepathy-marshal.h \
+ status-provider-telepathy-marshal.c
EXTRA_DIST = \
- status-service.xml
+ status-service.xml \
+ status-provider-pidgin.list \
+ status-provider-telepathy.list
CLEANFILES = \
$(BUILT_SOURCES)