aboutsummaryrefslogtreecommitdiff
path: root/src/gtk-dialog/Makefile.am
diff options
context:
space:
mode:
authorChristoph Korn <korn@ubuntu>2009-09-02 16:17:44 +0200
committerChristoph Korn <korn@ubuntu>2009-09-02 16:17:44 +0200
commit1f0874253406566587d4e42a9ee2f4617a5c66d9 (patch)
treecd8a07328b4a7fcdf836e6596c311a0640e2cf2d /src/gtk-dialog/Makefile.am
parent41f1b3206ab13b008aed6670dc42636049c9590d (diff)
downloadayatana-indicator-session-1f0874253406566587d4e42a9ee2f4617a5c66d9.tar.gz
ayatana-indicator-session-1f0874253406566587d4e42a9ee2f4617a5c66d9.tar.bz2
ayatana-indicator-session-1f0874253406566587d4e42a9ee2f4617a5c66d9.zip
These patches introduce a gconf key whether the logout/restart/shutdown confirmations
should be shown or not. Also the menu items should be suffixed by '...' accordingly. However this only works after a restart. Bugs which get fixed are: https://bugs.launchpad.net/indicator-session/+bug/422025 https://bugs.launchpad.net/ubuntu/+source/indicator-session/+bug/421693 https://bugs.launchpad.net/ubuntu/+source/indicator-session/+bug/419472
Diffstat (limited to 'src/gtk-dialog/Makefile.am')
-rw-r--r--src/gtk-dialog/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/gtk-dialog/Makefile.am b/src/gtk-dialog/Makefile.am
index 9aa0097..90a6209 100644
--- a/src/gtk-dialog/Makefile.am
+++ b/src/gtk-dialog/Makefile.am
@@ -5,9 +5,11 @@ gtk_logout_helper_SOURCES = \
gtk-logout-helper.c \
ck-pk-helper.c \
ck-pk-helper.h \
+ gconf-helper.c \
+ gconf-helper.h \
logout-dialog.c \
logout-dialog.h
-gtk_logout_helper_CFLAGS = $(GTKLOGOUTHELPER_CFLAGS) -Wall -Werror
-gtk_logout_helper_LDADD = $(GTKLOGOUTHELPER_LIBS)
+gtk_logout_helper_CFLAGS = $(GTKLOGOUTHELPER_CFLAGS) $(GCONF_CFLAGS) -Wall -Werror
+gtk_logout_helper_LDADD = $(GTKLOGOUTHELPER_LIBS) $(GCONF_LIBS)