aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-11-08 21:10:09 -0600
committerCharles Kerr <charles.kerr@canonical.com>2012-11-08 21:10:09 -0600
commit1e5206eed3848d8014a225b5d8252c5c7aeb137e (patch)
tree2c603624b84a99d4a8b9ee36ee0d0b4ee94543c3 /tests/Makefile.am
parent696c57e3fce174d7a30d2dd32cdb299c1dd663c3 (diff)
downloadayatana-indicator-session-1e5206eed3848d8014a225b5d8252c5c7aeb137e.tar.gz
ayatana-indicator-session-1e5206eed3848d8014a225b5d8252c5c7aeb137e.tar.bz2
ayatana-indicator-session-1e5206eed3848d8014a225b5d8252c5c7aeb137e.zip
ensure that the service unit test can find all the GSettings schemas that it needs.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index eedef3a..088b283 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -18,14 +18,16 @@ nodist_libgtest_a_SOURCES = \
AM_CPPFLAGS = $(GTEST_CPPFLAGS) -I${top_srcdir}/src -Wall -Werror
AM_CXXFLAGS = $(GTEST_CXXFLAGS)
+###
+###
+###
+
BUILT_SOURCES += gschemas.compiled
CLEANFILES += gschemas.compiled
gschemas.compiled: Makefile
- @glib-compile-schemas --targetdir=$(abs_builddir) $(top_builddir)/data
+ $(AM_V_at) cp -f $(top_builddir)/data/*gschema.xml .
+ $(AM_V_GEN) $(GLIB_COMPILE_SCHEMAS) --targetdir=. .
-###
-###
-###
TESTS += test-service
check_PROGRAMS += test-service
@@ -34,6 +36,7 @@ test_service_LDADD = \
$(TEST_SERVICE_LIBS) \
libgtest.a
test_service_CPPFLAGS = \
+ -DSCHEMA_DIR="\"$(top_builddir)/tests/\"" \
-DINDICATOR_SERVICE_DIR="\"$(abs_builddir)\"" \
-DINDICATOR_SERVICE_PATH="\"$(top_builddir)/src/indicator-session-service\"" \
$(TEST_SERVICE_CFLAGS) \