aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5850769..c9e4a44 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,8 +35,12 @@ dist-hook:
fi
TESTS = \
- test-ellipsis
+ test-ellipsis \
+ test-space-ellipsis
+#####
+# Tests for there being proper ellipsis instead of three periods in a row
+#####
test-ellipsis: po
@echo "#!/bin/bash" > $@
@echo "(cd po && make $(GETTEXT_PACKAGE).pot)" >> $@
@@ -44,4 +48,14 @@ test-ellipsis: po
@echo "exit 0" >> $@
@chmod +x $@
+#####
+# Tests for there being a space before an ellipsis
+#####
+test-space-ellipsis: po
+ @echo "#!/bin/bash" > $@
+ @echo "(cd po && make $(GETTEXT_PACKAGE).pot)" >> $@
+ @echo "grep -c -e \"^msgid.* …\\\"\" po/$(GETTEXT_PACKAGE).pot > /dev/null && echo \"Ellipsis found in user visible strings\" >&2 && exit 1" >> $@
+ @echo "exit 0" >> $@
+ @chmod +x $@
+
CLEANFILES = $(TESTS)