aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3e5fa97..a34450c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,6 +51,7 @@ AS_IF([test "x$with_gtk" = x3],
],
[AC_MSG_FAILURE([Value for --with-indicator-gtk was neither 2 nor 3])]
)
+
AC_SUBST(APPLET_CFLAGS)
AC_SUBST(APPLET_LIBS)
@@ -77,6 +78,11 @@ AS_IF([test "x$with_gtk" = x3],
AC_SUBST(SESSIONERVICE_CFLAGS)
AC_SUBST(SESSIONERVICE_LIBS)
+AM_CONDITIONAL([USE_GTK3], [test "x$with_gtk" = "x3"])
+AS_IF([test "x$with_gtk" = x3], [
+ AC_DEFINE(HAVE_GTK3, 1, [whether gtk3 is available])
+ ])
+
###########################
# GTK Logout Helper
###########################