aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am46
1 files changed, 44 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e2f0008..17d14e1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -11,7 +11,8 @@ sessionlib_LTLIBRARIES = libsession.la
libsession_la_SOURCES = \
indicator-session.c \
dbus-shared-names.h \
- status-service-client.h
+ status-service-client.h \
+ users-service-client.h
libsession_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Werror
libsession_la_LIBADD = $(APPLET_LIBS)
libsession_la_LDFLAGS = -module -avoid-version
@@ -25,8 +26,16 @@ indicator_status_service_SOURCES = \
status-service-dbus.h \
status-service-dbus.c \
status-service-server.h \
+ users-service-dbus.h \
+ users-service-dbus.c \
+ users-service-marshal.c \
+ users-service-marshal.h \
status-provider.h \
status-provider.c \
+ status-provider-mc5.h \
+ status-provider-mc5.c \
+ status-provider-mc5-marshal.h \
+ status-provider-mc5-marshal.c \
status-provider-pidgin.h \
status-provider-pidgin.c \
status-provider-pidgin-marshal.h \
@@ -38,6 +47,13 @@ indicator_status_service_SOURCES = \
indicator_status_service_CFLAGS = $(STATUSSERVICE_CFLAGS) -Wall -Werror
indicator_status_service_LDADD = $(STATUSSERVICE_LIBS)
+users-service-client.h: $(srcdir)/users-service.xml
+ dbus-binding-tool \
+ --prefix=_users_service_client \
+ --mode=glib-client \
+ --output=users-service-client.h \
+ $(srcdir)/users-service.xml
+
status-service-client.h: $(srcdir)/status-service.xml
dbus-binding-tool \
--prefix=_status_service_client \
@@ -52,6 +68,16 @@ status-service-server.h: $(srcdir)/status-service.xml
--output=status-service-server.h \
$(srcdir)/status-service.xml
+users-service-marshal.h: $(srcdir)/users-service.list
+ glib-genmarshal --header \
+ --prefix=_users_service_marshal $(srcdir)/users-service.list \
+ > users-service-marshal.h
+
+users-service-marshal.c: $(srcdir)/users-service.list
+ glib-genmarshal --body \
+ --prefix=_users_service_marshal $(srcdir)/users-service.list \
+ > users-service-marshal.c
+
status-provider-pidgin-marshal.h: $(srcdir)/status-provider-pidgin.list
glib-genmarshal --header \
--prefix=_status_provider_pidgin_marshal $(srcdir)/status-provider-pidgin.list \
@@ -72,11 +98,21 @@ status-provider-telepathy-marshal.c: $(srcdir)/status-provider-telepathy.list
--prefix=_status_provider_telepathy_marshal $(srcdir)/status-provider-telepathy.list \
> status-provider-telepathy-marshal.c
+status-provider-mc5-marshal.h: $(srcdir)/status-provider-mc5.list
+ glib-genmarshal --header \
+ --prefix=_status_provider_mc5_marshal $(srcdir)/status-provider-mc5.list \
+ > status-provider-mc5-marshal.h
+
+status-provider-mc5-marshal.c: $(srcdir)/status-provider-mc5.list
+ glib-genmarshal --body \
+ --prefix=_status_provider_mc5_marshal $(srcdir)/status-provider-mc5.list \
+ > status-provider-mc5-marshal.c
+
###############
# Users Stuff
###############
-indicator_users_service_SOURCES = users-service.c
+indicator_users_service_SOURCES = users-service.c users-service-dbus.c users-service-marshal.c
indicator_users_service_CFLAGS = $(USERSSERVICE_CFLAGS) -Wall -Werror
indicator_users_service_LDADD = $(USERSSERVICE_LIBS)
@@ -93,8 +129,13 @@ indicator_session_service_LDADD = $(SESSIONSERVICE_LIBS) $(GCONF_LIBS)
###############
BUILT_SOURCES = \
+ users-service-client.h \
status-service-client.h \
status-service-server.h \
+ status-provider-mc5-marshal.h \
+ status-provider-mc5-marshal.c \
+ users-service-marshal.h \
+ users-service-marshal.c \
status-provider-pidgin-marshal.h \
status-provider-pidgin-marshal.c \
status-provider-telepathy-marshal.h \
@@ -102,6 +143,7 @@ BUILT_SOURCES = \
EXTRA_DIST = \
status-service.xml \
+ status-provider-mc5.list \
status-provider-pidgin.list \
status-provider-telepathy.list