aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e2f0008..ae941e1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -27,6 +27,10 @@ indicator_status_service_SOURCES = \
status-service-server.h \
status-provider.h \
status-provider.c \
+ status-provider-mc5.h \
+ status-provider-mc5.c \
+ status-provider-mc5-marshal.h \
+ status-provider-mc5-marshal.c \
status-provider-pidgin.h \
status-provider-pidgin.c \
status-provider-pidgin-marshal.h \
@@ -72,6 +76,16 @@ status-provider-telepathy-marshal.c: $(srcdir)/status-provider-telepathy.list
--prefix=_status_provider_telepathy_marshal $(srcdir)/status-provider-telepathy.list \
> status-provider-telepathy-marshal.c
+status-provider-mc5-marshal.h: $(srcdir)/status-provider-mc5.list
+ glib-genmarshal --header \
+ --prefix=_status_provider_mc5_marshal $(srcdir)/status-provider-mc5.list \
+ > status-provider-mc5-marshal.h
+
+status-provider-mc5-marshal.c: $(srcdir)/status-provider-mc5.list
+ glib-genmarshal --body \
+ --prefix=_status_provider_mc5_marshal $(srcdir)/status-provider-mc5.list \
+ > status-provider-mc5-marshal.c
+
###############
# Users Stuff
###############
@@ -95,6 +109,8 @@ indicator_session_service_LDADD = $(SESSIONSERVICE_LIBS) $(GCONF_LIBS)
BUILT_SOURCES = \
status-service-client.h \
status-service-server.h \
+ status-provider-mc5-marshal.h \
+ status-provider-mc5-marshal.c \
status-provider-pidgin-marshal.h \
status-provider-pidgin-marshal.c \
status-provider-telepathy-marshal.h \
@@ -102,6 +118,7 @@ BUILT_SOURCES = \
EXTRA_DIST = \
status-service.xml \
+ status-provider-mc5.list \
status-provider-pidgin.list \
status-provider-telepathy.list