aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c03af4c..628056b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,20 +1,18 @@
+
AM_CPPFLAGS = $(GTEST_CPPFLAGS) $(INDICATOR_CFLAGS) -I${top_srcdir}/src -Wall -Werror
AM_CXXFLAGS = $(GTEST_CXXFLAGS)
+TESTS = test-service
check_PROGRAMS = test-service
test_service_SOURCES = test-service.cc
test_service_LDADD = $(TEST_SERVICE_LIBS) libgtest.a
-test_service_CPPFLAGS = $(TEST_SERVICE_CFLAGS) $(AM_CPPFLAGS)
+test_service_CPPFLAGS = \
+ $(TEST_SERVICE_CFLAGS) \
+ $(AM_CPPFLAGS) \
+ -DINDICATOR_SERVICE_PATH="\"$(top_builddir)/src/indicator-session-service\""
check_LIBRARIES = libgtest.a
nodist_libgtest_a_SOURCES = \
$(GTEST_SOURCE)/src/gtest-all.cc \
$(GTEST_SOURCE)/src/gtest_main.cc
-check_SCRIPTS = test-service-runner.sh
-test-service-runner.sh: Makefile.am
- @echo "#!/bin/sh" > $@
- @echo $(top_builddir)/tests/test-service $(top_builddir)/src/indicator-session-service$(EXEEXT) 2\>/dev/null >> $@
- @chmod +x $@
-
-TESTS = ${check_SCRIPTS}