aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-11-17 13:24:12 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-11-17 13:24:12 +0100
commit7b42e44ab6c32acba50a39d89e18e15d8507582c (patch)
treea603306b2a6ba80ca8053e48b18deccc1ee37cf5 /CMakeLists.txt
parent425c531ba241415514743f7cc6dae8c17683cb9f (diff)
parent88e440bb1689063c6d47ac7a4965eb597a8ec9cb (diff)
downloadayatana-indicator-sound-7b42e44ab6c32acba50a39d89e18e15d8507582c.tar.gz
ayatana-indicator-sound-7b42e44ab6c32acba50a39d89e18e15d8507582c.tar.bz2
ayatana-indicator-sound-7b42e44ab6c32acba50a39d89e18e15d8507582c.zip
Merge branch 'tari01-pr/refactor-schema-detection'
Attributes GH PR #66: https://github.com/AyatanaIndicators/ayatana-indicator-sound/pull/66
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3038762..7a5a37a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -63,6 +63,12 @@ pkg_check_modules(
include_directories(${SOUNDSERVICE_INCLUDE_DIRS})
pkg_check_modules(LOMIRI_API liblomiri-api>=0.1.1)
+pkg_check_modules(LOMIRI_SCHEMAS lomiri-schemas)
+
+# FIXME: Drop this block once lomiri-schemas has all the schemas: https://gitlab.com/ubports/core/lomiri-schemas/-/merge_requests/1
+if(LOMIRI_SCHEMAS_FOUND AND NOT EXISTS "/usr/share/accountsservice/interfaces/com.lomiri.AccountsService.Sound.xml")
+ set(LOMIRI_SCHEMAS_FOUND FALSE)
+endif()
include_directories(${TEST_INCLUDE_DIRS})