aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan LeSage <allanlesage@gmail.com>2011-12-06 19:31:29 -0600
committerAllan LeSage <allanlesage@gmail.com>2011-12-06 19:31:29 -0600
commit94f68e08df92dd859889d08706fe1f024f4962e8 (patch)
tree5fd4c30ce3243705ba87e6093a677bad70e12aed /configure.ac
parent3c02b69b2d0801d8a72c6016a41192b601ce4f2f (diff)
downloadayatana-indicator-sound-94f68e08df92dd859889d08706fe1f024f4962e8.tar.gz
ayatana-indicator-sound-94f68e08df92dd859889d08706fe1f024f4962e8.tar.bz2
ayatana-indicator-sound-94f68e08df92dd859889d08706fe1f024f4962e8.zip
Added coverage reporting via gcov config and targets.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5ee885a..5303ccc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,6 +100,16 @@ AC_SUBST(GCONF_CFLAGS)
AC_SUBST(GCONF_LIBS)
###########################
+# gcov coverage reporting
+###########################
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Check to see if we're local
###########################
@@ -198,4 +208,5 @@ SUS Indicator Configuration:
Prefix: $prefix
GTK+: $with_gtk
+ gcov: $use_gcov
])