aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorConor Curran <conor.curran@canonical.com>2010-03-24 15:47:37 +0000
committerConor Curran <conor.curran@canonical.com>2010-03-24 15:47:37 +0000
commitd7fbeccff7687eb1e50f6c35355a19e5433246c6 (patch)
tree45a7404fde9e8402c47779e9d5450d36e1680760 /configure.ac
parent65fde4c4a871479a5e9b58fb5e1c0e880b71b784 (diff)
parent017109c083b207d4a2bfb1d7d17e09aafc123b55 (diff)
downloadayatana-indicator-sound-d7fbeccff7687eb1e50f6c35355a19e5433246c6.tar.gz
ayatana-indicator-sound-d7fbeccff7687eb1e50f6c35355a19e5433246c6.tar.bz2
ayatana-indicator-sound-d7fbeccff7687eb1e50f6c35355a19e5433246c6.zip
Tests branch finally makes its way into trunk - more testing needed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c58595b..a0812d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,7 +23,7 @@ m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
###########################
# Dependencies
-###########################
+###########################
GTK_REQUIRED_VERSION=2.12
INDICATOR_REQUIRED_VERSION=0.3.6
@@ -34,7 +34,7 @@ INDICATOR_DISPLAY_OBJECTS=0.1.4
PKG_CHECK_MODULES(APPLET, gtk+-2.0 >= $GTK_REQUIRED_VERSION
indicator >= $INDICATOR_REQUIRED_VERSION
- dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION
+ dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION
libido-0.1 >= $INDICATOR_DISPLAY_OBJECTS)
AC_SUBST(APPLET_CFLAGS)
@@ -42,9 +42,12 @@ AC_SUBST(APPLET_LIBS)
DBUSMENUGLIB_REQUIRED_VERSION=0.1.1
+PKG_CHECK_MODULES(PULSEAUDIO, libpulse-mainloop-glib >= $PULSE_AUDIO_REQUIRED_VERSION)
+AC_SUBST(PULSEAUDIO_CFLAGS)
+AC_SUBST(PULSEAUDIO_LIBS)
+
PKG_CHECK_MODULES(SOUNDSERVICE, dbusmenu-glib >= $DBUSMENUGLIB_REQUIRED_VERSION
indicator >= $INDICATOR_REQUIRED_VERSION
- libpulse-mainloop-glib >= $PULSE_AUDIO_REQUIRED_VERSION
)
AC_SUBST(SOUNDSERVICE_CFLAGS)