aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastien Bacher <seb128@ubuntu.com>2012-02-14 20:46:41 +0100
committerPackage Import Robot <package-import@ubuntu.com>2012-02-14 20:46:41 +0100
commite49f20c921a9bb4b9232c495b91341a25e4a3bcb (patch)
tree1623ee0440ce55bbfe49ea420363dd32d1833522 /configure.ac
parent09e488c84fde89d63753cb6c167b06dae6c7407d (diff)
parent302256286a5e443a67592b7addd02c0633531cfc (diff)
downloadayatana-indicator-sound-e49f20c921a9bb4b9232c495b91341a25e4a3bcb.tar.gz
ayatana-indicator-sound-e49f20c921a9bb4b9232c495b91341a25e4a3bcb.tar.bz2
ayatana-indicator-sound-e49f20c921a9bb4b9232c495b91341a25e4a3bcb.zip
Import upstream version 0.8.1.0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 14 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0e88562..014cd1d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,10 +1,10 @@
-AC_INIT(indicator-sound, 0.8.0.0, conor.curran@canonical.com)
+AC_INIT(indicator-sound, 0.8.1.0, conor.curran@canonical.com)
AC_PREREQ(2.53)
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(indicator-sound, 0.8.0.0)
+AM_INIT_AUTOMAKE(indicator-sound, 0.8.1.0)
AM_MAINTAINER_MODE
@@ -42,7 +42,7 @@ AC_ARG_WITH([gtk],
GTK_REQUIRED_VERSION=2.22
GTK3_REQUIRED_VERSION=3.0
INDICATOR_REQUIRED_VERSION=0.3.19
-DBUSMENUGTK_REQUIRED_VERSION=0.3.101
+DBUSMENUGTK_REQUIRED_VERSION=0.5.90
POLKIT_REQUIRED_VERSION=0.92
PULSE_AUDIO_REQUIRED_VERSION=0.9.19
INDICATOR_DISPLAY_OBJECTS=0.1.11
@@ -90,6 +90,16 @@ AC_SUBST(SOUNDSERVICE_CFLAGS)
AC_SUBST(SOUNDSERVICE_LIBS)
###########################
+# gcov coverage reporting
+###########################
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Check to see if we're local
###########################
@@ -188,4 +198,5 @@ SUS Indicator Configuration:
Prefix: $prefix
GTK+: $with_gtk
+ gcov: $use_gcov
])