aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-08-05 08:03:26 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-08-05 08:03:26 +0200
commit28a25ffce39c2c47cd195208594a8b704097f0cf (patch)
tree2be6cd352faf71d9af95e9ce4b1c6319df6e88cb /data/CMakeLists.txt
parent3161efa0cba1ef81e6e7814a81d9aac73823f609 (diff)
parenta1c03e0a0f2e862f57f2f733067f2c0927568b98 (diff)
downloadayatana-indicator-sound-28a25ffce39c2c47cd195208594a8b704097f0cf.tar.gz
ayatana-indicator-sound-28a25ffce39c2c47cd195208594a8b704097f0cf.tar.bz2
ayatana-indicator-sound-28a25ffce39c2c47cd195208594a8b704097f0cf.zip
Merge branch 'tari01-pr/cmake-install-full'
Attributes GH PR #21: https://github.com/AyatanaIndicators/ayatana-indicator-sound/pull/21
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index ddfa2ad..e9ed905 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -7,7 +7,7 @@ find_package(GSettings)
set(
INDICATOR_DIR
- "${CMAKE_INSTALL_DATADIR}/ayatana/indicators"
+ "${CMAKE_INSTALL_FULL_DATADIR}/ayatana/indicators"
CACHE FILEPATH "Ayatana Indicators Directory"
)
@@ -75,19 +75,19 @@ endif()
#########################################
-set(POLKIT_LIB_DIR "${CMAKE_INSTALL_LOCALSTATEDIR}/lib/polkit-1")
-set(POLKIT_DATA_DIR "${CMAKE_INSTALL_PREFIX}/share/polkit-1")
-set(DBUS_IFACE_DIR "${CMAKE_INSTALL_PREFIX}/share/dbus-1/interfaces")
-set(ACCOUNTS_IFACE_DIR "${CMAKE_INSTALL_PREFIX}/share/accountsservice/interfaces")
+set(POLKIT_LIB_DIR "${CMAKE_INSTALL_FULL_LOCALSTATEDIR}/lib/polkit-1")
+set(POLKIT_DATA_DIR "${CMAKE_INSTALL_FULL_DATADIR}/polkit-1")
+set(DBUS_IFACE_DIR "${CMAKE_INSTALL_FULL_DATADIR}/dbus-1/interfaces")
+set(ACCOUNTS_IFACE_DIR "${CMAKE_INSTALL_FULL_DATADIR}/accountsservice/interfaces")
install(FILES org.ayatana.indicator.sound.AccountsService.xml
- DESTINATION "${DBUS_IFACE_DIR}"
+ DESTINATION "${DBUS_IFACE_DIR}"
)
# Create accountsservice symlink for above dbus interface
install(CODE "
- execute_process(COMMAND mkdir -p \"\$ENV{DESTDIR}${ACCOUNTS_IFACE_DIR}\")
- execute_process(COMMAND ln -sf ../../dbus-1/interfaces/org.ayatana.indicator.sound.AccountsService.xml \"\$ENV{DESTDIR}${ACCOUNTS_IFACE_DIR}\")
+ execute_process(COMMAND mkdir -p \"\$ENV{DESTDIR}${ACCOUNTS_IFACE_DIR}\")
+ execute_process(COMMAND ln -sf ../../dbus-1/interfaces/org.ayatana.indicator.sound.AccountsService.xml \"\$ENV{DESTDIR}${ACCOUNTS_IFACE_DIR}\")
")
install(FILES org.ayatana.indicator.sound.AccountsService.policy
@@ -126,4 +126,4 @@ else()
install(FILES 50-org.ayatana.AccountsService.Sound.pkla
DESTINATION "${POLKIT_LIB_DIR}/localauthority/10-vendor.d"
)
-endif() \ No newline at end of file
+endif()