aboutsummaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorConor Curran <conor.curran@canonical.com>2010-12-14 17:04:46 +0000
committerConor Curran <conor.curran@canonical.com>2010-12-14 17:04:46 +0000
commit7ef502c18c6ccf850c83fabebfb1884c458320b4 (patch)
tree421311e6467d077f975df3074c5e188adc0be6f1 /data/Makefile.am
parent8396e05ce716296377f2e4550e0c929dca30518e (diff)
downloadayatana-indicator-sound-7ef502c18c6ccf850c83fabebfb1884c458320b4.tar.gz
ayatana-indicator-sound-7ef502c18c6ccf850c83fabebfb1884c458320b4.tar.bz2
ayatana-indicator-sound-7ef502c18c6ccf850c83fabebfb1884c458320b4.zip
autofoo in order for gsettings
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am24
1 files changed, 9 insertions, 15 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 730f166..3f54f64 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -1,26 +1,20 @@
SUBDIRS = icons
+gsettings_SCHEMAS = \
+ com.canonical.indicators.sound.gschema.xml
+@GSETTINGS_RULES@
+
dbus_servicesdir = $(DBUSSERVICEDIR)
-service_in_files = indicator-sound.service.in
-dbus_services_DATA = $(service_in_files:.service.in=.service)
+dbus_services_DATA = indicator-sound.service
%.service: %.service.in
sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
-##############################
-# GSettings Schema
-##############################
-
-gsettings_SCHEMAS = \
- com.canonical.indicators.sound.gschema.xml
-@GSETTINGS_RULES@
-
-##############################
-EXTRA_DIST = \
- $(service_in_files) \
- $(gsettings_SCHEMAS)
+EXTRA_DIST = \
+ $(gsettings_SCHEMAS) \
+ indicator-sound.service.in
-CLEANFILES = \
+CLEANFILES = \
$(dbus_services_DATA)
\ No newline at end of file