aboutsummaryrefslogtreecommitdiff
path: root/data/icons/Makefile.am
diff options
context:
space:
mode:
authorConor Curran <conor.curran@canonical.com>2010-09-13 17:24:50 +0100
committerConor Curran <conor.curran@canonical.com>2010-09-13 17:24:50 +0100
commit0568dd3b8c0510269699d4f9f256b878137008d3 (patch)
treec8055b8dd481d4b018e92e5847b8888b4fa57f98 /data/icons/Makefile.am
parent410f37142bb9bc5f306b58292dcb8b975f52c9aa (diff)
parent11cb64daf79ff2a25b90c31c19c6f99263c42c5e (diff)
downloadayatana-indicator-sound-0568dd3b8c0510269699d4f9f256b878137008d3.tar.gz
ayatana-indicator-sound-0568dd3b8c0510269699d4f9f256b878137008d3.tar.bz2
ayatana-indicator-sound-0568dd3b8c0510269699d4f9f256b878137008d3.zip
merge the non-mono fix branch
Diffstat (limited to 'data/icons/Makefile.am')
-rw-r--r--data/icons/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/data/icons/Makefile.am b/data/icons/Makefile.am
new file mode 100644
index 0000000..b671b5c
--- /dev/null
+++ b/data/icons/Makefile.am
@@ -0,0 +1,15 @@
+SUBDIRS = scalable 16x16
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(pkgdatadir)/icons/hicolor
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+