aboutsummaryrefslogtreecommitdiff
path: root/data/icons/Makefile.am
diff options
context:
space:
mode:
authorConor Curran <conor.curran@canonical.com>2010-09-13 15:35:13 +0100
committerConor Curran <conor.curran@canonical.com>2010-09-13 15:35:13 +0100
commitd14c4fa661af70a2d3eda9ceeb1c1c0fa5a28a93 (patch)
tree290d9114b074f4d34686521faf3a2e4ea4749a38 /data/icons/Makefile.am
parentaf31c744cee14a2fadac8f72111f1b422de9f7a7 (diff)
downloadayatana-indicator-sound-d14c4fa661af70a2d3eda9ceeb1c1c0fa5a28a93.tar.gz
ayatana-indicator-sound-d14c4fa661af70a2d3eda9ceeb1c1c0fa5a28a93.tar.bz2
ayatana-indicator-sound-d14c4fa661af70a2d3eda9ceeb1c1c0fa5a28a93.zip
added scalable sound-icon svg to the assets
Diffstat (limited to 'data/icons/Makefile.am')
-rw-r--r--data/icons/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/data/icons/Makefile.am b/data/icons/Makefile.am
new file mode 100644
index 0000000..8b476c3
--- /dev/null
+++ b/data/icons/Makefile.am
@@ -0,0 +1,15 @@
+SUBDIRS = scalable
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(pkgdatadir)/icons/hicolor
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+