aboutsummaryrefslogtreecommitdiff
path: root/data/icons/Makefile.am
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2010-09-14 15:13:49 -0400
committerKen VanDine <ken.vandine@canonical.com>2010-09-14 15:13:49 -0400
commit51fbe7e43942f7fb94f6a26fd917cf181cde58af (patch)
treee8cd5c0133819afdccf0010f6785cad816857a54 /data/icons/Makefile.am
parente9a955249e88474858861e944ace11d55245d967 (diff)
parent4b7abb73527b7ce240c15d408b00afa6a80a3c07 (diff)
downloadayatana-indicator-sound-51fbe7e43942f7fb94f6a26fd917cf181cde58af.tar.gz
ayatana-indicator-sound-51fbe7e43942f7fb94f6a26fd917cf181cde58af.tar.bz2
ayatana-indicator-sound-51fbe7e43942f7fb94f6a26fd917cf181cde58af.zip
Import upstream version 0.4.5
Diffstat (limited to 'data/icons/Makefile.am')
-rw-r--r--data/icons/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/data/icons/Makefile.am b/data/icons/Makefile.am
new file mode 100644
index 0000000..b671b5c
--- /dev/null
+++ b/data/icons/Makefile.am
@@ -0,0 +1,15 @@
+SUBDIRS = scalable 16x16
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(pkgdatadir)/icons/hicolor
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+