aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2011-06-28 06:51:51 -0400
committerBazaar Package Importer <james.westby@ubuntu.com>2011-06-28 06:51:51 -0400
commit1f4af1902d3de115a0e0bf9ce3fd6f5e829fed18 (patch)
tree1e4a64e2bfa4e2485ecdafb0e049f518833231a3 /debian/rules
parenta16822cf5cf1435e10e34850affcac24687da130 (diff)
parentd6c3971f3dc1d69de7e6f937b4bc0aa82842b05f (diff)
downloadayatana-indicator-sound-1f4af1902d3de115a0e0bf9ce3fd6f5e829fed18.tar.gz
ayatana-indicator-sound-1f4af1902d3de115a0e0bf9ce3fd6f5e829fed18.tar.bz2
ayatana-indicator-sound-1f4af1902d3de115a0e0bf9ce3fd6f5e829fed18.zip
* New upstream release.
- "Sound Preferences..." should be "Sound Settings" (LP: #785571) - Not obvious what track info menu item does (LP: #699899) * debian/patches/lp_750823.patch - Dropped patch, merged upstream * debian/patches/gtk3_define.patch - Wrap another gtk3 block in an ifdef * debian/control - Updated standards version to 3.9.2 - Cleaned up description to quiet lintian - Added quilt build dep
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules25
1 files changed, 14 insertions, 11 deletions
diff --git a/debian/rules b/debian/rules
index d778ba1..7950ed1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,20 +1,23 @@
#!/usr/bin/make -f
+DEB_BUILDDIR = build
+DEB_MAKE_FLAVORS = gtk2 gtk3
+
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/gnome.mk
-include /usr/share/cdbs/1/rules/simple-patchsys.mk
-include /usr/share/cdbs/1/rules/autoreconf.mk
-# List any files which are not installed
-include /usr/share/cdbs/1/rules/utils.mk
-common-binary-post-install-arch:: list-missing
+DEB_MAKE_DESTDIRSKEL = $(CURDIR)/debian/tmp/@FLAVOR@
+DEB_DESTDIR = $(CURDIR)/debian/tmp/$(cdbs_make_curflavor)/
-LDFLAGS += -Wl,-z,defs -Wl,-O1 -Wl,--as-needed
+DEB_CONFIGURE_FLAGS_gtk2 = --with-gtk=2
+DEB_CONFIGURE_FLAGS_gtk3 = --with-gtk=3
+DEB_CONFIGURE_EXTRA_FLAGS = --disable-static
-DEB_DH_MAKESHLIBS_ARGS = -Xusr/lib/indicators
+LDFLAGS += -Wl,-z,defs -Wl,--as-needed
-binary-install/indicator-sound::
- # remove .a/.la clutter
- rm -f debian/$(cdbs_curpkg)/usr/lib/indicators/*/*.a
- rm -f debian/$(cdbs_curpkg)/usr/lib/indicators/*/*.la
+debian/stamp-autotools/gtk2: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk2)
+debian/stamp-autotools/gtk3: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk3)
+common-install-arch::
+ find debian/tmp -name \*.la -delete
+ find debian/tmp -name \*.a -delete