aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2013-10-28 17:49:04 -0700
committerTed Gould <ted@gould.cx>2013-10-28 17:49:04 -0700
commit4f6b673281fecd22c618c700af0bd798ee5c26f1 (patch)
tree9bc4564892d82786c6e00c446dda58bb100c9e9c /src/CMakeLists.txt
parentfd5fc9ed4aca0753779432de3ccc60cce6499af3 (diff)
parenta440eb1df8296a6b431613ec03aac94db38292c6 (diff)
downloadayatana-indicator-sound-4f6b673281fecd22c618c700af0bd798ee5c26f1.tar.gz
ayatana-indicator-sound-4f6b673281fecd22c618c700af0bd798ee5c26f1.tar.bz2
ayatana-indicator-sound-4f6b673281fecd22c618c700af0bd798ee5c26f1.zip
Merge trunk
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt13
1 files changed, 5 insertions, 8 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ec43b8f..572befd 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -14,12 +14,15 @@ vala_init(indicator-sound-service
libxml-2.0
libpulse
libpulse-mainloop-glib
+ libnotify
OPTIONS
--ccode
--thread
--vapidir=${CMAKE_SOURCE_DIR}/vapi/
--vapidir=.
--target-glib=2.36
+ --pkg=url-dispatcher
+ --pkg=bus-watcher
)
vala_add(indicator-sound-service
@@ -47,19 +50,12 @@ vala_add(indicator-sound-service
media-player-list.vala
DEPENDS
media-player
- mpris2-watcher
+ mpris2-interfaces
)
vala_add(indicator-sound-service
mpris2-interfaces.vala
)
vala_add(indicator-sound-service
- mpris2-watcher.vala
- DEPENDS
- media-player
- mpris2-interfaces
- freedesktop-interfaces
-)
-vala_add(indicator-sound-service
freedesktop-interfaces.vala
)
vala_add(indicator-sound-service
@@ -89,6 +85,7 @@ set(
INDICATOR_SOUND_SOURCES
${project_VALA_SOURCES}
${project_VALA_C}
+ bus-watch-namespace.c
${SYMBOLS_PATH}
)