aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorConor Curran <conor.curran@canonical.com>2010-03-18 20:20:26 +0000
committerConor Curran <conor.curran@canonical.com>2010-03-18 20:20:26 +0000
commitb26c97936312634da3fb30e818a76ce2a5a03992 (patch)
tree7bd1abcdb49ab687338e40068ec75a24a199e1ca /src/Makefile.am
parent69049dd2d6011e9ab96f4f439d00e1de98178449 (diff)
parentda7146ab578829c406c4d3ccde8b89443ba634c9 (diff)
downloadayatana-indicator-sound-b26c97936312634da3fb30e818a76ce2a5a03992.tar.gz
ayatana-indicator-sound-b26c97936312634da3fb30e818a76ce2a5a03992.tar.bz2
ayatana-indicator-sound-b26c97936312634da3fb30e818a76ce2a5a03992.zip
merged in updates from trunk and fixed the tests on the indicator
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am20
1 files changed, 2 insertions, 18 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8ddcff5..d9fd14c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -11,9 +11,7 @@ libsoundmenu_la_SOURCES = \
indicator-sound.h \
indicator-sound.c \
dbus-shared-names.h \
- sound-service-client.h \
- sound-service-marshal.c \
- sound-service-marshal.h
+ sound-service-client.h
libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Werror
libsoundmenu_la_LIBADD = $(APPLET_LIBS)
@@ -30,16 +28,6 @@ sound-service-client.h: $(srcdir)/sound-service.xml
--output=sound-service-client.h \
$(srcdir)/sound-service.xml
-sound-service-marshal.h: $(srcdir)/sound-service.list
- glib-genmarshal --header \
- --prefix=_sound_service_marshal $(srcdir)/sound-service.list \
- > sound-service-marshal.h
-
-sound-service-marshal.c: $(srcdir)/sound-service.list
- glib-genmarshal --body \
- --prefix=_sound_service_marshal $(srcdir)/sound-service.list \
- > sound-service-marshal.c
-
#################
# Session Stuff
@@ -55,8 +43,6 @@ indicator_sound_service_SOURCES = \
sound-service-dbus.h \
sound-service-dbus.c \
sound-service-server.h \
- sound-service-marshal.c \
- sound-service-marshal.h \
slider-menu-item.h \
slider-menu-item.c
indicator_sound_service_CFLAGS = $(PULSEAUDIO_CFLAGS) $(SOUNDSERVICE_CFLAGS) $(GCONF_CFLAGS) -DLIBEXECDIR=\"$(libexecdir)\" -Wall -Werror
@@ -74,9 +60,7 @@ sound-service-server.h: $(srcdir)/sound-service.xml
###############
BUILT_SOURCES = \
sound-service-client.h \
- sound-service-server.h \
- sound-service-marshal.h \
- sound-service-marshal.c
+ sound-service-server.h
EXTRA_DIST = \
sound-service.xml \