aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2013-03-06 22:40:55 -0500
committerLars Uebernickel <lars.uebernickel@canonical.com>2013-03-06 22:40:55 -0500
commitea30986e03e54ee650a1cca610904de9f4d0f745 (patch)
treef7b0ccde687b306216db06fc9762e67679b6e86f /src/Makefile.am
parentce02b10b74faab8a5934688b7e3759cba56864ef (diff)
downloadayatana-indicator-sound-ea30986e03e54ee650a1cca610904de9f4d0f745.tar.gz
ayatana-indicator-sound-ea30986e03e54ee650a1cca610904de9f4d0f745.tar.bz2
ayatana-indicator-sound-ea30986e03e54ee650a1cca610904de9f4d0f745.zip
Remove libsoundmenu (panel plugin)
Indicator panel plugins are deprecated.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am38
1 files changed, 0 insertions, 38 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5a36822..a56f82a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,43 +1,5 @@
libexec_PROGRAMS = indicator-sound-service
-###################
-# Indicator Stuff
-###################
-
-soundmenulibdir = $(INDICATORDIR)
-soundmenulib_LTLIBRARIES = libsoundmenu.la
-libsoundmenu_la_SOURCES = \
- common-defs.h \
- indicator-sound.h \
- indicator-sound.c \
- sound-state.c \
- sound-state.h \
- sound-state-manager.c \
- sound-state-manager.h \
- transport-widget.c \
- transport-widget.h \
- metadata-widget.c \
- metadata-widget.h \
- mute-widget.c \
- mute-widget.h \
- volume-widget.c \
- volume-widget.h \
- voip-input-widget.c \
- voip-input-widget.h \
- gen-sound-service.xml.h \
- gen-sound-service.xml.c \
- dbus-shared-names.h
-
-libsoundmenu_la_CFLAGS = \
- $(APPLET_CFLAGS) \
- $(COVERAGE_CFLAGS) \
- -Wall -Werror -DG_LOG_DOMAIN=\"Indicator-Sound\"
-libsoundmenu_la_LIBADD = $(APPLET_LIBS) -lm
-libsoundmenu_la_LDFLAGS = \
- $(COVERAGE_LDFLAGS) \
- -module -avoid-version
-
-
checkxml: $(srcdir)/sound-service.xml
@xmllint -valid -noout $<
@echo $< checks out ok