aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorConor Curran <conor.curran@canonical.com>2011-06-21 18:26:10 +0200
committerConor Curran <conor.curran@canonical.com>2011-06-21 18:26:10 +0200
commita6dee99edd1a3870c4dc4557f605578c52a4f0dc (patch)
tree6945b0519d0579577c0d8cd5316c626215449c77 /src/Makefile.am
parent5e112656817e193c26ee462f4beffb83c08858f4 (diff)
downloadayatana-indicator-sound-a6dee99edd1a3870c4dc4557f605578c52a4f0dc.tar.gz
ayatana-indicator-sound-a6dee99edd1a3870c4dc4557f605578c52a4f0dc.tar.bz2
ayatana-indicator-sound-a6dee99edd1a3870c4dc4557f605578c52a4f0dc.zip
custom marshaller in place to handle the string string signature on our item specific dbus methods
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fde333a..fedf5de 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -30,6 +30,7 @@ libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Werror -DG_LOG_DOMAIN=\"Indicat
libsoundmenu_la_LIBADD = $(APPLET_LIBS)
libsoundmenu_la_LDFLAGS = -module -avoid-version
+
checkxml: $(srcdir)/sound-service.xml
@xmllint -valid -noout $<
@echo $< checks out ok
@@ -39,6 +40,9 @@ checkxml: $(srcdir)/sound-service.xml
# Sound Service
####################################################################
+glib_marshal_list = sound-service-marshal.list
+glib_marshal_prefix = _sound_service_marshal
+
#####################
# Sound service vala
@@ -106,6 +110,8 @@ indicator_sound_service_SOURCES = \
mute-menu-item.c \
gen-sound-service.xml.h \
gen-sound-service.xml.c \
+ sound-service-marshal.c \
+ sound-service-marshal.h \
$(music_bridge_VALASOURCES:.vala=.c)
indicator_sound_service_CFLAGS = $(PULSEAUDIO_CFLAGS) $(SOUNDSERVICE_CFLAGS) $(GCONF_CFLAGS) -DLIBEXECDIR=\"$(libexecdir)\" -Wall
@@ -146,3 +152,7 @@ BUILT_SOURCES = \
CLEANFILES = \
$(BUILT_SOURCES)
+
+DISTCLEANFILES =
+
+include $(top_srcdir)/Makefile.am.marshal