aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMarco Trevisan (Treviño) <mail@3v1n0.net>2013-04-02 17:54:12 +0200
committerMarco Trevisan (Treviño) <mail@3v1n0.net>2013-04-02 17:54:12 +0200
commitba80753bb0a79f052f007c6e614732afac88e3ad (patch)
tree712b7df53e5b4639a463da34c9687caf07bfb76b /src/Makefile.am
parente6779eca9277231ee59c6441bf6982599a0d611e (diff)
downloadayatana-indicator-sound-ba80753bb0a79f052f007c6e614732afac88e3ad.tar.gz
ayatana-indicator-sound-ba80753bb0a79f052f007c6e614732afac88e3ad.tar.bz2
ayatana-indicator-sound-ba80753bb0a79f052f007c6e614732afac88e3ad.zip
PlayerActivator: Use BAMF to find the windows to activate with timestamp
Improved the"old" GtkApplicationPlayer, using BAMF as a fallback method to activate an application's windows. Basically we try to get the windows of the selected application and when found we focus them using the activation timestamp.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 381da56..9807477 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -68,7 +68,7 @@ music_bridge_VALASOURCES = \
playlists-menu-item.vala \
freedesktop-interfaces.vala \
fetch-file.vala \
- gtk-application-player.vala
+ player-windows-activator.vala
music_bridge_VALAFLAGS = \
--ccode \
@@ -83,7 +83,9 @@ music_bridge_VALAFLAGS = \
--pkg gio-2.0 \
--pkg gio-unix-2.0 \
--pkg gdk-3.0 \
+ --pkg gdk-x11-3.0 \
--pkg gdk-pixbuf-2.0 \
+ --pkg libbamf3 \
--pkg libxml-2.0
$(MAINTAINER_VALAFLAGS)