aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorConor Curran <conor.curran@canonical.com>2010-03-11 17:23:13 +0000
committerConor Curran <conor.curran@canonical.com>2010-03-11 17:23:13 +0000
commitb4dfb37242eb867798f778a80d5ece48a568630b (patch)
tree5c02f8b9a80eb444569ac783d47fb9dc29f40534 /src/Makefile.am
parent633b514efeaf1c4086e1b2e5fbef185b199517c8 (diff)
parent0391c21a9205ecf2a182a217d74e3f4d3177f81e (diff)
downloadayatana-indicator-sound-b4dfb37242eb867798f778a80d5ece48a568630b.tar.gz
ayatana-indicator-sound-b4dfb37242eb867798f778a80d5ece48a568630b.tar.bz2
ayatana-indicator-sound-b4dfb37242eb867798f778a80d5ece48a568630b.zip
merged weeks work plus incremented version in prep for 0.1.3 release
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am18
1 files changed, 2 insertions, 16 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 40a8fdd..73bb259 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -11,9 +11,7 @@ libsoundmenu_la_SOURCES = \
indicator-sound.h \
indicator-sound.c \
dbus-shared-names.h \
- sound-service-client.h \
- sound-service-marshal.c \
- sound-service-marshal.h
+ sound-service-client.h
libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Werror
libsoundmenu_la_LIBADD = $(APPLET_LIBS)
@@ -30,16 +28,6 @@ sound-service-client.h: $(srcdir)/sound-service.xml
--output=sound-service-client.h \
$(srcdir)/sound-service.xml
-sound-service-marshal.h: $(srcdir)/sound-service.list
- glib-genmarshal --header \
- --prefix=_sound_service_marshal $(srcdir)/sound-service.list \
- > sound-service-marshal.h
-
-sound-service-marshal.c: $(srcdir)/sound-service.list
- glib-genmarshal --body \
- --prefix=_sound_service_marshal $(srcdir)/sound-service.list \
- > sound-service-marshal.c
-
#################
# Session Stuff
@@ -74,9 +62,7 @@ sound-service-server.h: $(srcdir)/sound-service.xml
###############
BUILT_SOURCES = \
sound-service-client.h \
- sound-service-server.h \
- sound-service-marshal.h \
- sound-service-marshal.c
+ sound-service-server.h
EXTRA_DIST = \
sound-service.xml \