aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSebastien Bacher <seb128@ubuntu.com>2010-03-11 23:53:14 +0100
committerSebastien Bacher <seb128@ubuntu.com>2010-03-11 23:53:14 +0100
commitad7fe51b593322771b1b9104d0c9c39ba0607085 (patch)
tree6c7ed47f80672d654d4d705fd75c972ee63b9007 /src/Makefile.am
parent4ff15dc31c6e0b5703ead3341a02fed9a45025f7 (diff)
parent6df1024fe1a7cbfb9f6ba38cfe33a04889c2d40f (diff)
downloadayatana-indicator-sound-ad7fe51b593322771b1b9104d0c9c39ba0607085.tar.gz
ayatana-indicator-sound-ad7fe51b593322771b1b9104d0c9c39ba0607085.tar.bz2
ayatana-indicator-sound-ad7fe51b593322771b1b9104d0c9c39ba0607085.zip
releasing version 0.1.3-0ubuntu1
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am21
1 files changed, 5 insertions, 16 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 543ec58..73bb259 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,11 +8,10 @@ soundmenulibdir = $(INDICATORDIR)
soundmenulib_LTLIBRARIES = libsoundmenu.la
libsoundmenu_la_SOURCES = \
common-defs.h \
+ indicator-sound.h \
indicator-sound.c \
dbus-shared-names.h \
- sound-service-client.h \
- sound-service-marshal.c \
- sound-service-marshal.h
+ sound-service-client.h
libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Werror
libsoundmenu_la_LIBADD = $(APPLET_LIBS)
@@ -29,16 +28,6 @@ sound-service-client.h: $(srcdir)/sound-service.xml
--output=sound-service-client.h \
$(srcdir)/sound-service.xml
-sound-service-marshal.h: $(srcdir)/sound-service.list
- glib-genmarshal --header \
- --prefix=_sound_service_marshal $(srcdir)/sound-service.list \
- > sound-service-marshal.h
-
-sound-service-marshal.c: $(srcdir)/sound-service.list
- glib-genmarshal --body \
- --prefix=_sound_service_marshal $(srcdir)/sound-service.list \
- > sound-service-marshal.c
-
#################
# Session Stuff
@@ -47,6 +36,8 @@ indicator_sound_service_SOURCES = \
common-defs.h \
sound-service.h \
sound-service.c \
+ dbus-menu-manager.c \
+ dbus-menu-manager.h \
pulse-manager.h \
pulse-manager.c \
sound-service-dbus.h \
@@ -71,9 +62,7 @@ sound-service-server.h: $(srcdir)/sound-service.xml
###############
BUILT_SOURCES = \
sound-service-client.h \
- sound-service-server.h \
- sound-service-marshal.h \
- sound-service-marshal.c
+ sound-service-server.h
EXTRA_DIST = \
sound-service.xml \