aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2013-04-04 05:51:55 +0200
committerLars Uebernickel <lars.uebernickel@canonical.com>2013-04-04 05:51:55 +0200
commit838d4366a4c5e159ef7cde4caef4d908730df3a7 (patch)
treebe2c10bb1ed240af73abcfb1c89f476d4e298972 /src/Makefile.am
parenteb24b0dbee584427991ae49cbcb94893bdbd47c2 (diff)
downloadayatana-indicator-sound-838d4366a4c5e159ef7cde4caef4d908730df3a7.tar.gz
ayatana-indicator-sound-838d4366a4c5e159ef7cde4caef4d908730df3a7.tar.bz2
ayatana-indicator-sound-838d4366a4c5e159ef7cde4caef4d908730df3a7.zip
Don't build unused files and remove superseded files
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am56
1 files changed, 1 insertions, 55 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1de360c..993b0d2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,10 +1,5 @@
libexec_PROGRAMS = indicator-sound-service
-checkxml: $(srcdir)/sound-service.xml
- @xmllint -valid -noout $<
- @echo $< checks out ok
-
-
####################################################################
# Sound Service
####################################################################
@@ -22,19 +17,9 @@ music_bridge_VALASOURCES = \
volume-control.vala \
media-player.vala \
media-player-list.vala \
- music-player-bridge.vala \
- transport-menu-item.vala \
- specific-items-manager.vala \
- metadata-menu-item.vala \
- player-controller.vala \
mpris2-interfaces.vala \
mpris2-watcher.vala \
- mpris2-controller.vala \
- player-item.vala \
- settings-manager.vala \
- playlists-menu-item.vala \
- freedesktop-interfaces.vala \
- fetch-file.vala
+ freedesktop-interfaces.vala
music_bridge_VALAFLAGS = \
--ccode \
@@ -52,7 +37,6 @@ music_bridge_VALAFLAGS = \
--pkg libxml-2.0 \
--pkg libpulse \
--pkg libpulse-mainloop-glib \
- --pkg pulseaudio-mgr \
--target-glib=2.36
$(MAINTAINER_VALAFLAGS)
@@ -69,24 +53,6 @@ music_bridge_vala.stamp $(music_bridge_APIFILES): $(music_bridge_VALASOURCES)
###############################
indicator_sound_service_SOURCES = \
common-defs.h \
- sound-state.c \
- sound-state.h \
- pulseaudio-mgr.h \
- pulseaudio-mgr.c \
- device.c \
- device.h \
- sound-service-dbus.h \
- sound-service-dbus.c \
- slider-menu-item.h \
- slider-menu-item.c \
- voip-input-menu-item.h \
- voip-input-menu-item.c \
- mute-menu-item.h \
- mute-menu-item.c \
- gen-sound-service.xml.h \
- gen-sound-service.xml.c \
- sound-service-marshal.c \
- sound-service-marshal.h \
$(music_bridge_VALASOURCES:.vala=.c)
indicator_sound_service_CFLAGS = $(PULSEAUDIO_CFLAGS) \
@@ -97,26 +63,8 @@ indicator_sound_service_CFLAGS = $(PULSEAUDIO_CFLAGS) \
indicator_sound_service_LDADD = $(PULSEAUDIO_LIBS) $(SOUNDSERVICE_LIBS) $(GCONF_LIBS)
indicator_sound_service_LDFLAGS = $(COVERAGE_LDFLAGS)
-#########################
-# Service xml compilation
-#########################
-DBUS_SPECS = \
- sound-service.xml
-
-gen-%.xml.h: %.xml
- @echo "Building $@ from $<"
- @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<))));" > $@
-
-gen-%.xml.c: %.xml
- @echo "Building $@ from $<"
- @echo "const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<)))) = " > $@
- @sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
- @echo ";" >> $@
-
-
EXTRA_DIST = \
$(DBUS_SPECS) \
- sound-service.xml \
$(music_bridge_APIFILES) \
$(music_bridge_VALASOURCES)
@@ -126,8 +74,6 @@ EXTRA_DIST = \
BUILT_SOURCES = \
music_bridge_vala.stamp \
$(music_bridge_APIFILES) \
- gen-sound-service.xml.h \
- gen-sound-service.xml.c \
$(music_bridge_VALASOURCES:.vala=.c)
CLEANFILES = \