aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2013-03-27 13:06:26 -0400
committerLars Uebernickel <lars.uebernickel@canonical.com>2013-03-27 13:06:26 -0400
commitc3d504bc66bbd360ca6c8d5742a121441dacbfe2 (patch)
tree0435c45826c757ba125515933e9a11a927d45eb3 /src/Makefile.am
parent5cd2cc805d012b0e019a4d30f3666cb60707ca76 (diff)
downloadayatana-indicator-sound-c3d504bc66bbd360ca6c8d5742a121441dacbfe2.tar.gz
ayatana-indicator-sound-c3d504bc66bbd360ca6c8d5742a121441dacbfe2.tar.bz2
ayatana-indicator-sound-c3d504bc66bbd360ca6c8d5742a121441dacbfe2.zip
Add VolumeControl and hook up mute and volume actions to it
The VolumeControl class originated in the phablet branch of this indicator.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 39ec6bf..2421683 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -19,6 +19,7 @@ glib_marshal_prefix = _sound_service_marshal
music_bridge_VALASOURCES = \
service.vala \
main.vala \
+ volume-control.vala \
music-player-bridge.vala \
transport-menu-item.vala \
specific-items-manager.vala \
@@ -48,6 +49,8 @@ music_bridge_VALAFLAGS = \
--pkg gdk-pixbuf-2.0 \
--pkg libxml-2.0 \
--pkg libpulse \
+ --pkg libpulse-mainloop-glib \
+ --pkg pulseaudio-mgr \
--target-glib=2.36
$(MAINTAINER_VALAFLAGS)