aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2011-06-28 10:51:50 -0400
committerKen VanDine <ken.vandine@canonical.com>2011-06-28 10:51:50 -0400
commitfbe33a6d8e37468d5f01c5747c9ccb1763208db6 (patch)
tree91f441e199f5b319b30f21fbbe421323dc9bdc2a /src/Makefile.am
parentb004f06319c37e63adee52cff5a6258e900ad8a2 (diff)
parentf11a6bb0c8bc68d0a6972e94140f7b5d96881dba (diff)
downloadayatana-indicator-sound-fbe33a6d8e37468d5f01c5747c9ccb1763208db6.tar.gz
ayatana-indicator-sound-fbe33a6d8e37468d5f01c5747c9ccb1763208db6.tar.bz2
ayatana-indicator-sound-fbe33a6d8e37468d5f01c5747c9ccb1763208db6.zip
Import upstream version 0.7.2
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c546f0f..e35f871 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -118,11 +118,11 @@ DBUS_SPECS = \
gen-%.xml.h: %.xml
@echo "Building $@ from $<"
- @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $<)));" > $@
+ @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<))));" > $@
gen-%.xml.c: %.xml
@echo "Building $@ from $<"
- @echo "const char * _$(subst -,_,$(subst .,_,$(basename $<))) = " > $@
+ @echo "const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<)))) = " > $@
@sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
@echo ";" >> $@