aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2014-03-25 08:53:07 -0500
committerTed Gould <ted@gould.cx>2014-03-25 08:53:07 -0500
commita7ede233e186d15bf3187c5b0dadde68be5b5779 (patch)
tree35897a717eb244b8c55f6dc0e538e79495267425 /tests/CMakeLists.txt
parentb40acd218400d189f7c41e063f2437496073d40e (diff)
parentda388be5f313d0517a730bda29104c10ad326716 (diff)
downloadayatana-indicator-sound-a7ede233e186d15bf3187c5b0dadde68be5b5779.tar.gz
ayatana-indicator-sound-a7ede233e186d15bf3187c5b0dadde68be5b5779.tar.bz2
ayatana-indicator-sound-a7ede233e186d15bf3187c5b0dadde68be5b5779.zip
Adding a test that previously failed, but should work on this branch
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 9b0586a..ae68c45 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -158,3 +158,26 @@ add_test(media-player-user-test-timeout
media-player-user-test --gtest_filter=MediaPlayerUserTest.TimeoutTest
)
+###########################
+# Greeter List
+###########################
+
+include_directories(${CMAKE_SOURCE_DIR}/src)
+add_executable (greeter-list-test greeter-list.cc)
+target_link_libraries (
+ greeter-list-test
+ indicator-sound-service-lib
+ vala-mocks-lib
+ gtest
+ ${SOUNDSERVICE_LIBRARIES}
+ ${TEST_LIBRARIES}
+)
+
+# Split tests to work around libaccountservice sucking
+add_test(greeter-list-test-basic
+ greeter-list-test --gtest_filter=GreeterListTest.BasicObject
+)
+add_test(greeter-list-test-iterator
+ greeter-list-test --gtest_filter=GreeterListTest.BasicIterator
+)
+