aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2015-02-19 16:27:24 +0000
committerCI Train Bot <ci-train-bot@canonical.com>2015-02-19 16:27:24 +0000
commit14be74296b0bd81a797373c4c972916277d0428e (patch)
tree6833db57605bf225620214218a427fe0f0a4444b /tests/CMakeLists.txt
parent403caf562ba967342b78d5491229fe40cc908361 (diff)
parent18891aa50808f29365f763cc503e5dfa2e17ab17 (diff)
downloadayatana-indicator-sound-14be74296b0bd81a797373c4c972916277d0428e.tar.gz
ayatana-indicator-sound-14be74296b0bd81a797373c4c972916277d0428e.tar.bz2
ayatana-indicator-sound-14be74296b0bd81a797373c4c972916277d0428e.zip
Add notifications mock and tests
Approved by: Jussi Pakkanen, PS Jenkins bot
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 38a76ae..6e30bf5 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -65,6 +65,14 @@ vala_add(vala-mocks
media-player-mock.vala
)
+vala_add(vala-mocks
+ media-player-list-mock.vala
+)
+
+vala_add(vala-mocks
+ volume-control-mock.vala
+)
+
vala_finish(vala-mocks
SOURCES
vala_mocks_VALA_SOURCES
@@ -184,6 +192,24 @@ target_link_libraries (
add_test(sound-menu-test sound-menu-test)
###########################
+# Notification Test
+###########################
+
+include_directories(${CMAKE_SOURCE_DIR}/src)
+add_executable (notifications-test notifications-test.cc)
+target_link_libraries (
+ notifications-test
+ indicator-sound-service-lib
+ vala-mocks-lib
+ pulse-mock
+ gtest
+ ${SOUNDSERVICE_LIBRARIES}
+ ${TEST_LIBRARIES}
+)
+
+add_test(notifications-test notifications-test)
+
+###########################
# Accounts Service User
###########################