aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2015-01-29 17:31:24 +0000
committerCI Train Bot <ci-train-bot@canonical.com>2015-01-29 17:31:24 +0000
commit9aa6a9af39006d4bceb445aeb9707559f40424f1 (patch)
tree1ad26fe8bfa0a60a5c2d24c523d45fcfb2abf5b0 /tests/CMakeLists.txt
parentf393b1688218d1e773f235ca03d49735ed03ff5d (diff)
parent7f8f6bf4c2da5056fec32c82986c4f5af20113a9 (diff)
downloadayatana-indicator-sound-9aa6a9af39006d4bceb445aeb9707559f40424f1.tar.gz
ayatana-indicator-sound-9aa6a9af39006d4bceb445aeb9707559f40424f1.tar.bz2
ayatana-indicator-sound-9aa6a9af39006d4bceb445aeb9707559f40424f1.zip
Build a rudimentary Pulse Audio mock for testing.
Approved by: Antti Kaijanmäki, Jussi Pakkanen, PS Jenkins bot
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index ae68c45..fb93aca 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -83,6 +83,16 @@ target_link_libraries(
include_directories(${CMAKE_CURRENT_BINARY_DIR})
###########################
+# Pulse Mock
+###########################
+
+add_library(
+ pulse-mock
+ SHARED
+ pa-mock.cpp
+)
+
+###########################
# Name Watch Test
###########################
@@ -116,6 +126,22 @@ add_test(accounts-service-user-test-player
)
###########################
+# Volume Control
+###########################
+
+include_directories(${CMAKE_SOURCE_DIR}/src)
+add_executable (volume-control-test volume-control-test.cc)
+target_link_libraries (
+ volume-control-test
+ indicator-sound-service-lib
+ pulse-mock
+ gtest
+ ${TEST_LIBRARIES}
+)
+
+add_test(volume-control-test volume-control-test)
+
+###########################
# Sound Menu
###########################