aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorConor Curran <conor.curran@canonical.com>2010-02-24 14:19:01 +0000
committerConor Curran <conor.curran@canonical.com>2010-02-24 14:19:01 +0000
commitc879c510dbef95deea70687d59c2013005bf946d (patch)
tree9b71d7a2cce23f04b31442b8d582caac0ac08489 /tests/Makefile.am
parent191f8934b194f2728e175b228f1931f28c1ab8fa (diff)
downloadayatana-indicator-sound-c879c510dbef95deea70687d59c2013005bf946d.tar.gz
ayatana-indicator-sound-c879c510dbef95deea70687d59c2013005bf946d.tar.bz2
ayatana-indicator-sound-c879c510dbef95deea70687d59c2013005bf946d.zip
unit tests for the indicator side added
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..05e1bd0
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,23 @@
+
+check_PROGRAMS = \
+ test-indicator-sound
+
+TESTS =
+DISTCLEANFILES = $(TESTS)
+
+#########################################
+## test-indicator-sound
+#########################################
+test_indicator_sound_SOURCES = \
+ test-indicator-sound.c
+
+test_indicator_sound_CFLAGS = \
+ $(APPLET_CFLAGS) \
+ -Wall -Werror \
+ -I$(srcdir) \
+ -DBUILD_DIR="\"$(builddir)\""
+
+test_indicator_sound_LDADD = \
+ $(APPLET_LIBS) \
+ $(INDICATORDIR)/libsoundmenu.la
+